POJ - 2976 Dropping tests(01分数规划)

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

给出ai,bi及以下式子,求去掉k个对应的ai,bi后,该式子的最大值是多少?

.

01分数规划解析博客

二分时注意上下界的

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<map>
#include<vector>
#include<iostream>
#define ll long long
#define inf 0x3f3f3f3f
const double esp=1e-7;
using namespace std;
const int maxn=1010;
double a[maxn];
double b[maxn];
double d[maxn];
int n,k;
double er_fen(double l,double r)
{
    while(r-l>=esp)
    {
        double mid=(l+r)/2;
        for(int i=0;i<n;i++)
        d[i]=a[i]-mid*b[i];
        sort(d,d+n);
        double ans=0.0;
        for(int i=k;i<n;i++)
        ans+=d[i];
        if(ans>0) l=mid;
        else r=mid;
     }
    return l;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        if(!n&&!k) break;
        for(int i=0;i<n;i++)
        scanf("%lf",&a[i]);
        for(int i=0;i<n;i++)
        scanf("%lf",&b[i]);
        double l=inf,r=0;
        for(int i=0;i<n;i++)
        {
            l=min(l,a[i]/b[i]);
            r=max(r,a[i]/b[i]);
        }
      printf("%.0f\n",er_fen(l,r)*100);
    }
}

定位取值。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值