122 Triangular Sums

Triangular Sums

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 2
描述

The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…nk * T(k + 1)]

输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210

4 10 2145


#include <iostream>

using namespace std;

int main()
{
	int N;
	int j = 0;
	cin >> N;

	while(N--)
	{
		int sum = 0;
		int n;
		int T = 1;
		cin >> n;
		for(int i = 1; i <= n; i++)
		{
			T += (i + 1);
			sum += i * T;
		}
		j++;
		cout << j << " " << n << " " << sum << endl;
	}
	return 0;
}

每一个输入就是一个从小到大求和, 再按照规定的格式输出结果就好了

优秀代码:

#include<iostream>
using namespace std;
const int M=310;
int W[M];
int main()
{
	
	for(int i=1;i!=M;i++)
		W[i]=W[i-1]+i*(i+1)*(i+2)/2;
	int m,n;
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		cin>>m;
		cout<<i<<" "<<m<<" "<<W[m]<<endl;
	}
}                

因为题干中已经说明数据范围<=300,所以一个310的数组足够保存所有的结果,用一个循环将所有可能的数据全部计算出来,再用一个循环输出所需要的数据结果。

最近脑子是秀逗了么,明知道效率没法比,还总是爱写嵌套,因小失大,算法是要看整个程序的运行效率,不能只关注局部而忽视了全局


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值