1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 353608    Accepted Submission(s): 68625


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

代码
#include <iostream>
#include <string>

using namespace std;
string sum(string s1, string s2)
{
    if (s1.length()<s2.length())
    {
        string temp = s1;
        s1 = s2;
        s2 = temp;
    }
    int i, j;
    for (i = s1.length() - 1, j = s2.length() - 1; i >= 0; i--, j--)
    {
        s1[i] = char(s1[i] + (j >= 0 ? s2[j] - '0' : 0));   //注意细节  
        if (s1[i] - '0' >= 10)
        {
            s1[i] = char((s1[i] - '0') % 10 + '0');
            if (i) s1[i - 1]++;
            else s1 = '1' + s1;
        }
    }
    return s1;
}
int main()
{
    int n;
    int k = 0, m = 0;
    cin >> n;
    while (k++ < n)
    {
        //题意要求保留原来的大数 
        string a, b, s;
        cin >> a >> b;
        cout << "Case " << k << ":" << endl;
        cout << a << " + " << b << " = ";
        if (a.length() < b.length())
        {
            string temp = a;
            a = b;
            b = temp;
        }
        s = a;
        //length后的-1不能忘记 
        for (int i = a.length() - 1, j = b.length() - 1; i >= 0; --i, --j)
        {
            if (j >= 0)
                s[i] = s[i] + b[j] - '0';
            if (s[i] > '9')
            {
                s[i] = s[i] - 10;
                if (i)
                    ++s[i - 1];
                else
                    //最高位需要进位的时候,在最前面+1位 
                    s = '1' + s;
            }
        }
        //s = sum(a, b);
        
         cout << s << endl;
        if (++m < n)
            cout << endl;
    }
    return 0;
}

大数运算,写个模板就可以了,HDU上输出格式尤其要注意,经常性的格式出错


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值