HDU 3835 R(N)

10 篇文章 0 订阅

                                                                 R(N)

Problem Description
We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example,
10=(-3)^2+1^2.
We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).


Input
No more than 100 test cases. Each case contains only one integer N(N<=10^9).


Output
For each N, print R(N) in one line.


Sample Input
2
6
10
25
65


Sample Output
4
0
8
12
16
HintFor

the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)

题意:这个题目的意思还是很容易看懂的吧....输入一个数,看它能否表示成两个数的平方和,求这样的两个数的组合有几个.其实只有找到自然数中的两个构成这样的数的组合,然后给数加符号就行了.

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int n,ans;
	int i,j,temp;
	while(cin>>n)
	{
		ans=0;
		for(i=0;i<=(double)sqrt((double)n);i++)
		{
			temp=n-i*i;
			temp=(double)sqrt((double)temp);
			if(n==temp*temp+i*i)         //先取根,再平方相加判断是否为两个自然数平分之和
			{
				//不难理解,当两个数中有一个0时,另一个可取正或负,当两个数都不为0,加符号则有四种情况
				if(i==0 || temp==0)
					ans+=2;         
				else
					ans+=4;
			}
		}
		cout<<ans<<endl;
	}
	return 0;
}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值