This challenge is part of a tutorial track by MyCodeSchool
You’re given the pointer to the head nodes of two sorted linked lists. The data in both lists will be sorted in ascending order. Change the next
pointers to obtain a single, merged linked list which also has data in ascending order. Either head pointer given may be null meaning that the corresponding list is empty.
Input Format
You have to complete the Node* MergeLists(Node* headA, Node* headB)
method which takes two arguments - the heads of the two sorted linked lists to merge. You should NOT read any input from stdin/console.
Output Format
Change the next
pointer of individual nodes so that nodes from both lists are merged into a single list. Then return
the head of this merged list. Do NOT print anything to stdout/console.
Sample Input
1 -> 3 -> 5 -> 6 -> NULL
2 -> 4 -> 7 -> NULL
15 -> NULL
12 -> NULL
NULL
1 -> 2 -> NULL
Sample Output
1 -> 2 -> 3 -> 4 -> 5 -> 6 -> 7
12 -> 15 -> NULL
1 -> 2 -> NULL
Explanation
1. We merge elements in both list in sorted order and output.
cpp code :
#include <iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
struct Node
{
int data;
Node *next;
};/*
Merge two sorted lists A and B as one linked list
Node is defined as
struct Node
{
int data;
struct Node *next;
}
*/
Node* MergeLists(Node *headA, Node* headB)
{
// This is a "method-only" submission.
// You only need to complete this method
if(headA == NULL)
return headB;
else if(headB == NULL)
return headA;
Node *res = NULL;
if(headA->data < headB->data)
{
res = headA;
res->next = MergeLists(headA->next, headB);
}
else
{
res = headB;
res ->next = MergeLists(headA, headB->next);
}
return res;
}void Print(Node *head)
{
bool ok = false;
while(head != NULL)
{
if(ok)cout<<" ";
else ok = true;
cout<<head->data;
head = head->next;
}
cout<<"\n";
}
Node* Insert(Node *head,int x)
{
Node *temp = new Node();
temp->data = x;
temp->next = NULL;
if(head == NULL)
{
return temp;
}
Node *temp1;
for(temp1 = head;temp1->next!=NULL;temp1= temp1->next);
temp1->next = temp;return head;
}
int main()
{
int t;
cin>>t;
while(t-- >0)
{
Node *A = NULL;
Node *B = NULL;
int m;cin>>m;
while(m--){
int x; cin>>x;
A = Insert(A,x);}
int n; cin>>n;
while(n--){
int y;cin>>y;
B = Insert(B,y);
}
A = MergeLists(A,B);
Print(A);
}
}