1032. Sharing (25)

1032. Sharing (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:

 
 

11111 22222 9 67890 i 00002 00010 a 12345 00003 g -1 12345 D 67890 00002 n 00003 22222 B 23456 11111 L 00001 23456 e 67890 00001 o 00010

Sample Output 1:

 
 

67890

Sample Input 2:

 
 

00001 00002 4 00001 a 10001 10001 s -1 00002 a 10002 10002 t -1

Sample Output 2:

 
 

-1


这道题无语的地方在于支持开大数组,而用stl里的map会超时?。。。。。。。。我自己用map写的,最后一个测试点过不去,网上的做法简单很多,开一个大数组下表对应地址。
#include<iostream>  
using namespace std;  
#include<cstring>  
int map[100005];  
int vst[100005] = { 0 };  
int main(){  
    memset(map, -1, sizeof(map));  
    int add1, add2, n;  
    cin >> add1 >> add2 >> n;  
    for (int i = 0; i < n; i++){  
        int a, b; char ch;  
        cin >> a >> ch >> b;  
        map[a] = b;  
    }  
    int add = add1;  
    while (add != -1){  
        vst[add] = 1;  
        add = map[add];  
    }  
    add = add2;  
    while (add != -1 && !vst[add]){  
        add = map[add];  
    }  
    if (add == -1)  
        printf("-1");  
    else  
        printf("%05d", add);  
}  

自己用map的版本
#include<iostream>
#include<fstream>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#define inf 1000000
using namespace std;
struct NODE
{
	string addr;
	char data;
	string Next;
};
int main()
{
	//ifstream fin("Text.txt");
	map<string, int>cup;
	string head1;
	string head2;
	int N;
	cin >> head1 >> head2 >> N;
	int i,j;
	string addr,next;
	char ch;
	struct NODE* List = new struct NODE[N];
	for (i = 0; i < N; i++)
	{
		cin >> addr >> ch >> next;
		cup[addr] = i;
		List[i].addr = addr;
		List[i].data = ch;
		List[i].Next = next;
	}
	vector<int>str1;
	vector<int>str2;
	string tmp;
	tmp = head1;
	while (tmp != "-1")
	{
		i = cup[tmp];
		str1.push_back(i);
		tmp = List[i].Next;
	}
	tmp = head2;
	while (tmp != "-1")
	{
		i = cup[tmp];
		str2.push_back(i);
		tmp = List[i].Next;
	}
	int index = -1;
	for (i = str1.size()-1,j=str2.size()-1; i>=0&&j>=0; i--,j--)
	{
		if (str1[i] == str2[j])
		{
			index = i;
		}
		else break;
	}
	
	if (index == -1)cout << index;
	else
	{
		i = str1[index];
		cout << List[i].addr;
	}
	delete[]List;
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值