[PAT]1032. Sharing (25)(Java实现)

1032. Sharing (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1

解题思路:建立字母类,并且加上一个flag标志。然后从第一个单词的头结点开始遍历,把遍历到的节点flag设为1;

然后从第二个单词头结点开始遍历,当遇到第一个flag为1的字母时,这个就是所求的字母


java运行太慢了,以下程序在PAT有时能通过,有时候过不了。

如果有更好的解法,请留言交流,谢谢!


package go.jacob.day1128;

import java.util.HashMap;
import java.util.Map;
import java.util.Scanner;

/**
 * 1032. Sharing (25)
 * 
 * 
 */
public class Demo3 {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		Integer src1 = sc.nextInt(), src2 = sc.nextInt();
		int n = sc.nextInt();
		int res = -1;
		Map<Integer, Word> map = new HashMap<Integer, Word>();
		for (int i = 0; i < n; i++) {
			Integer add = sc.nextInt();
			char c = sc.next().charAt(0);
			Integer next = sc.nextInt();
			Word w = new Word(add, c, next);
			map.put(add, w);
		}
		sc.close();
		while (!src1.equals(-1)) {
			Word w = map.get(src1);
			w.flag = 1;
			src1 = w.next;
		}

		while (!src2.equals(-1)) {
			Word w = map.get(src2);
			if (w.flag.equals(1)) {
				res = w.add;
			}
			src2 = w.next;
		}
		if (res == -1)
			System.out.println(-1);
		else
			System.out.printf("%05d", res);
	}
}

class Word {
	Integer add;
	char c;
	Integer next;
	Integer flag = 0;

	public Word(Integer add, char c, Integer next) {
		super();
		this.add = add;
		this.c = c;
		this.next = next;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值