1037. Magic Coupon (25)

1037. Magic Coupon (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

 
 

4 1 2 4 -1 4 7 6 -2 -3

Sample Output:

#include<iostream>  
#include<vector>  
#include<iterator>  
#include<algorithm>  
  
using namespace std;  
  
bool cmp(int a, int b){  
    return a > b;  
}  
  
int main(){  
    vector<int> pos_a, pos_b, neg_a,neg_b;  
    int m, n, temp;  
    int ans = 0;//最终结果  
    cin >> m;  
    for (int i = 0; i < m; i++){  
        cin >> temp;  
        if (temp >= 0)  
            pos_a.push_back(temp);  
        else  
            neg_a.push_back(-temp);  
    }  
    cin >> n;  
    for (int i = 0; i < n; i++){  
        cin >> temp;  
        if (temp >= 0)  
            pos_b.push_back(temp);  
        else  
            neg_b.push_back(-temp);  
    }  
    sort(pos_a.begin(), pos_a.end(), cmp);  
    sort(pos_b.begin(), pos_b.end(), cmp);  
    sort(neg_a.begin(), neg_a.end(), cmp);  
    sort(neg_b.begin(), neg_b.end(), cmp);  
    vector<int>::iterator a = pos_a.begin(), b = pos_b.begin();  
  
    while (a != pos_a.end() && b != pos_b.end()){  
        ans += *a * *b;  
        a++; b++;  
    }  
    a = neg_a.begin(), b = neg_b.begin();  
    while (a != neg_a.end() && b != neg_b.end()){  
        ans += *a * *b;  
        a++, b++;  
    }  
    cout << ans << endl;  
    return 0;  
}  

 
 

43


自己的有一个测试点运行超时

#include<iostream>
#include<fstream>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>

#define inf 1000000
using namespace std;
bool compA(int i, int j)
{
	return i > j;
}
bool compB(int i, int j)
{
	return i < j;
}
int main()
{
	
	int N1, N2;
	
	//if (N1 == 0 || N2 == 0)return 0;
	int i, j;
	vector<int>cou;
	vector<int>pro;
	cin >> N1;
	i = N1;
	while (i--)
	{
		cin >> j;
		cou.push_back(j);
	}
	cin >> N2;
	i = N2;
	while (i--)
	{
		cin >> j;
		pro.push_back(j);
	}
	int sum = 0;
	sort(cou.begin(), cou.end(),compA);
	sort(pro.begin(), pro.end(),compA);
	while (!cou.empty() && !pro.empty())
	{
		i = cou[0];
		j = pro[0];
		if (i <0 || j< 0)break;
		else 
		{
			cou.erase(cou.begin());
			pro.erase(pro.begin());
			sum += i * j;
		}
	}
	if (!cou.empty() && !pro.empty())
	{
		sort(cou.begin(), cou.end(), compB);
		sort(pro.begin(), pro.end(), compB);
		while (!cou.empty() && !pro.empty())
		{
			i = cou[0];
			j = pro[0];
			if (i >0 || j> 0)break;
			else
			{
				cou.erase(cou.begin());
				pro.erase(pro.begin());
				sum += i * j;
			}
		}

	}
	cout << sum;
		
		return 0;
	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值