poj1463 Strategic game

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

  • the number of nodes
  • the description of each node in the following format
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
    or
    node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source



这题属于典型的树形dp……,之所以典型捏,是因为连我都看得出来-_-|||

好,不说废话了,这题讲的是给一棵树,问最少选择多少个节点使得其他没选到的节点与这些点相邻。

对于每个点都有两种情况,要么选,要么不选,如果选了的话,那么他的子节点就可以不选,而如果他没选,则子节点必有一个要选,所以状态转移方程就直接出来了。

代码

    #include <stdio.h>
    #include <vector>
    using namespace std;

    #define INF 99999999

    vector <int> edge[2005];
    int dp[2005][2];
    int n;

    void DFS(int t,int p)
    {
        int i,k;
        if (edge[t].size()==1 && p!=-1)
        {
            dp[t][0]=0;
            dp[t][1]=1;
            return;
        }
        dp[t][0]=dp[t][1]=0;
        for (i=0;i<edge[t].size();i++)
        {
            k=edge[t][i];
            if (k==p) continue;
            DFS(k,t);
            dp[t][0]+=dp[k][1];
            dp[t][1]+=min(dp[k][0],dp[k][1]);
        }
        dp[t][1]++;
    }

    int main()
    {
        int i,j,x,y,k;
        while(scanf("%d",&n)!=EOF)
        {
            for (i=0;i<n;i++)
            {
                edge[i].clear();
            }
            for (i=0;i<n;i++)
            {
                scanf("%d:(%d)",&x,&k);
                while(k--)
                {
                    scanf("%d",&y);
                    edge[x].push_back(y);
                    edge[y].push_back(x);
                }
            }
            DFS(0,-1);
            printf("%d\n",min(dp[0][0],dp[0][1]));
        }
        return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值