HDU 1002 A+B 高精度

http://acm.hdu.edu.cn/showproblem.php?pid=1002

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

题目大意:模拟高精度加法。

思路:用数组存储每一位就可存储很大的数据了。注意有个坑点,最后一次输出一个换行就行了。

#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;
using namespace std;

int a[1010];

int main()
{
	int t;
	scanf("%d",&t);
	string s1,s2;
	int times=0;
	while(t--)
	{
		cin>>s1>>s2;
		memset(a,0,sizeof(a));
		int k=1005;
		int i=s1.size()-1,j=s2.size()-1;
		for(;i>=0&&j>=0;i--,j--)
			a[k--]=s1[i]+s2[j]-48-48;
		while(i>=0)
			a[k--]=s1[i--]-48;
		while(j>=0)
			a[k--]=s2[j--]-48;
		for(int r=1005;r>k;r--)
		{
			a[r-1]+=a[r]/10;
			a[r]%=10;
		}
		if(a[k]==0)
			k++;
		printf("Case %d:\n",++times);
		cout<<s1<<" + "<<s2<<" = ";
		for(int i=k;i<=1005;i++)
			printf("%d",a[i]);
		printf("\n");
		if(t)
			printf("\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值