http://acm.hdu.edu.cn/showproblem.php?pid=1711
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
Sample Output
6 -1
题目大意:在原序列a中找到b序列的起始位置。(即定位模式串)若没有则输出-1。
思路:KMP算法。下面那篇博客是对KMP的简单介绍。
https://blog.csdn.net/xiji333/article/details/88614354
#include<iostream>
#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;
int s1[1000005];
int s2[10005];
int Next[10005];
int n,m;
void getnext()
{
int i=0,k=-1;
Next[0]=-1;
while(i<m-1)
{
if(k==-1||s2[i]==s2[k])
{
if(s2[++i]==s2[++k])
Next[i]=Next[k];
else
Next[i]=k;
}
else
k=Next[k];
}
}
int kmp()
{
int i=0,j=0;
while(i<n&&j<m)
{
if(j==-1||s1[i]==s2[j])
++i,++j;
else
j=Next[j];
}
if(j==m)
return i-j+1;
else
return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&s1[i]);
for(int i=0;i<m;i++)
scanf("%d",&s2[i]);
getnext();
printf("%d\n",kmp());
}
return 0;
}