HDU 2833 WuKong 弗洛伊德+dp

http://acm.hdu.edu.cn/showproblem.php?pid=2833、

Liyuan wanted to rewrite the famous book “Journey to the West” (“Xi You Ji” in Chinese pinyin). In the original book, the Monkey King Sun Wukong was trapped by the Buddha for 500 years, then he was rescued by Tang Monk, and began his journey to the west. Liyuan thought it is too brutal for the monkey, so he changed the story:

One day, Wukong left his home - Mountain of Flower and Fruit, to the Dragon   King’s party, at the same time, Tang Monk left Baima Temple to the Lingyin Temple to deliver a lecture. They are both busy, so they will choose the shortest path. However, there may be several different shortest paths between two places. Now the Buddha wants them to encounter on the road. To increase the possibility of their meeting, the Buddha wants to arrange the two routes to make their common places as many as possible. Of course, the two routines should still be the shortest paths.

Unfortunately, the Buddha is not good at algorithm, so he ask you for help.

Input

There are several test cases in the input. The first line of each case contains the number of places N (1 <= N <= 300) and the number of roads M (1 <= M <= N*N), separated by a space. Then M lines follow, each of which contains three integers a b c, indicating there is a road between place a and b, whose length is c. Please note the roads are undirected. The last line contains four integers A B C D, separated by spaces, indicating the start and end points of Wukong, and the start and end points of Tang Monk respectively.

The input are ended with N=M=0, which should not be processed.

Output

Output one line for each case, indicating the maximum common points of the two shortest paths.

Sample Input

6 6
1 2 1
2 3 1
3 4 1
4 5 1
1 5 2
4 6 3
1 6 2 4
0 0

Sample Output

3

Hint: One possible arrangement is (1-2-3-4-6) for Wukong and (2-3-4) for Tang Monk. The number of common points are 3.

题目大意:给出两对起点和终点:b1、e1和b2、e2,求b1-e1的最短路径和b2-e2的最短路径的最多公共点个数。

思路:dp,弗洛伊德算法其实也是dp的思想,我们用dp[i][j]表示从i到j的最短路径最多有几个点。然后在弗洛伊德算法中加上这个更新就好了。然后枚举一条从i到j的最短路径a[i][j],满足b1-e1的最短路径和b2-e2的最短路径都经过a[i][j],记录最大值即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<map>
#include<algorithm>
#include<sstream>
#include<cctype>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

int a[305][305];
int dp[305][305];//记录从i到j的最短路径最多有几个点
int n,m;

void floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(i==j||i==k||j==k)
                    continue;
                if(a[i][k]+a[k][j]<a[i][j])
                {
                    a[i][j]=a[i][k]+a[k][j];
                    dp[i][j]=dp[i][k]+dp[k][j]-1;//k算了两次
                }
                else if(a[i][k]+a[k][j]==a[i][j])
                    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]-1);
            }
        }
    }
}

int main()
{
    while(~scanf("%d %d",&n,&m)&&n+m)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                a[i][j]=INF;
                dp[i][j]=2;//两个点
            }
            a[i][i]=0;
            dp[i][i]=1;//1个点
        }
        int t1,t2,t3;
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&t1,&t2,&t3);
            a[t1][t2]=a[t2][t1]=min(a[t1][t2],t3);//重边
        }
        floyd();
        int MAX=0;
        int b1,b2,e1,e2;
        scanf("%d %d %d %d",&b1,&e1,&b2,&e2);
        if(a[b1][e1]==INF||a[b2][e2]==INF)//不可达
            printf("0\n");
        else
        {
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    if(a[b1][i]+a[i][j]+a[j][e1]==a[b1][e1]&&a[b2][i]+a[i][j]+a[j][e2]==a[b2][e2])//寻找最短路径的共同部分
                        MAX=max(MAX,dp[i][j]);
            printf("%d\n",MAX);
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值