CSU 2220 Godsend 简单博弈论 思维

http://acm.csu.edu.cn:20080/csuoj/problemset/problem?pid=2220

Description

Leha somehow found an array consisting of n integers. Looking at it, he came up with a task. Two players play the game on the array. Players move one by one. The first player can choose for his move a subsegment of non-zero length with an odd sum of numbers and remove it from the array, after that the remaining parts are glued together into one array and the game continues. The second player can choose a subsegment of non-zero length with an even sum and remove it. Loses the one who can not make a move. Who will win if both play optimally?

Input

First line of input data contains single integer n (1 ≤ n ≤ 1000000) — length of the array.

Next line contains n integers a1, a2, ..., an (0 ≤ ai ≤ 1000000000).

Output

Output answer in single line.

"First", if first player wins, and "Second" otherwise (without quotes).

Sample Input

4
1 3 2 3

Sample Output

First

题目大意:有两个人在一个序列上进行操作,当有k个连续元素之和为奇数时,A可以删去这k个元素,当和为偶数时,B可以删去这k个元素。(k由自己决定)现在A先开始,问谁能赢?

思路:简单博弈论,当n个元素之和sum为奇数时,A全部拿走;当sum为偶数且序列中有1个奇数时,A拿走这个奇数,此时sum变为奇数,B不能获胜,且B操作之后sum仍为奇数,因此A胜;否则B胜。

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
using namespace std;

long long sum=0;
int flag=0;
int n,t;

int main()
{
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&t);
		if(t&1)
			flag=1;
		sum+=t;
	}
	if(sum&1||flag)
		printf("First\n");
	else
		printf("Second\n");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值