http://poj.org/problem?id=3264
For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3 1 7 3 4 2 5 1 5 4 6 2 2
Sample Output
6 3 0
题目大意:n个数,m次查询,输出[l,r]内的最大值与最小值的差。
思路:没有修改操作,所以直接用st表,模板题。
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int st1[50005][32];
int st2[50005][32];
int a[50005];
int n,m;
inline void init()
{
int MAX=log2(n);
for(int i=1;i<=n;i++)
st1[i][0]=st2[i][0]=a[i];
for(int j=1;j<=MAX;j++)
{
for(int i=1;i<=n;i++)
{
if(i+(1<<j)-1<=n)
{
st1[i][j]=max(st1[i][j-1],st1[i+(1<<(j-1))][j-1]);
st2[i][j]=min(st2[i][j-1],st2[i+(1<<(j-1))][j-1]);
}
else
break;
}
}
}
inline void query(int l,int r)
{
int len=r-l+1;
int t=log2(len);
int MAX=max(st1[l][t],st1[r-(1<<t)+1][t]);
int MIN=min(st2[l][t],st2[r-(1<<t)+1][t]);
printf("%d\n",MAX-MIN);
}
int main()
{
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
init();
int l,r;
for(int i=0;i<m;i++)
{
scanf("%d %d",&l,&r);
query(l,r);
}
return 0;
}