CSU 2259 King's Colors 二项式反演

http://acm.csu.edu.cn:20080/csuoj/problemset/problem?pid=2259

Description

Far, far away, there is the mystical Kingdom of Trees (more formally, "Royal Commonwealth of Connected Undirected Simple Acyclic Graphs"). The King there is very sad because his kingdom is not accepted as a sovereign state in the United Nations. In order to become a member, he needs to make a flag the UN can put on their website.

The flag will of course consist of the King's favorite tree, which contains n nodes. The King would be happy to just have the tree colored in black and white, but for the sake of his wife the Queen, he decided that the tree will contain all the favorite colors of their k children (they all have distinct favorite colors). Clearly, no two neighboring nodes can have the same color, but otherwise any coloring of the tree using exactly the k colors would make a feasible flag candidate.

How many different flags are possible?

Input

The first line contains two integers n and k (2 ≤ k ≤ n ≤ 2 500), where n is the number of nodes in the King's favorite tree and k is the number of children. Then follow n − 1 lines describing the edges in the tree; the i'th of these lines contains a non-negative integer pi < i, meaning that node pi is the parent of i.

The nodes are numbered from 0 to n − 1 and the tree is rooted at node 0. Note that the embedding of the tree on the flag is already fixed, the only thing that remains is to assign colors.

Output

Output the number of different possible color assignments. The number can be quite big, so the King has requested to know the answer modulo 1 000 000 007​.

Sample Input

4 3
0
1
1
-----------------------
6 4
0
1
1
3
4

Sample Output

18
----------------------
600

Hint

Source

ncpc2018

题目大意:给一颗有n个节点的数用k种颜色染色,要求任意两个相邻节点的颜色不同且恰好使用了k种颜色,问有多少种方案数?

思路:二项式反演。设Fi为最多使用了i种颜色染色的方案数,Ti为恰好使用了i种颜色染色的方案数,由组合数学知识可得:

F_{k}=\sum_{i=0}^{k}C_{k}^{i}*T_{i},那么由二项式反演可得:T_{k}=\sum_{i=0}^{k}(-1)^{k-i}*C_{k}^{i}*F_{i},因此只要我们知道了Fi的值,就可以累加得到Tk也即答案的值。考虑Fi的意义:在树上染色使相邻节点的颜色不同,那么只要使节点与其父节点(如果存在的话)的颜色不同即可,因此F_{i}=i*(i-1)^{n-1}。组合数也很好算,利用公式C_{n}^{m}=C_{n-1}^{m-1}+C_{n-1}^{m}即可。

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;

ll C[2505][2505];//组合数
ll f[2505];
ll xs[2505];
ll n,k;
const ll MOD=1e9+7;

ll pow(ll a,ll b)
{
	ll t1=1,t2=a;
	while(b)
	{
		if(b&1)
			t1=(t1*t2)%MOD;
		t2=(t2*t2)%MOD;
		b>>=1;
	}
	return t1;
}

void init()
{
	for(ll i=0;i<=k;i++)
	{
		f[i]=(i*pow(i-1,n-1))%MOD;
		C[i][i]=C[i][0]=1;
		if((k-i)&1)
			xs[i]=-1;
		else
			xs[i]=1;
		for(int j=1;j<i;j++)
			C[i][j]=(C[i-1][j-1]+C[i-1][j])%MOD;
	}
}

int main()
{
	scanf("%lld %lld",&n,&k);
	int t;
	for(int i=1;i<n;i++)
		scanf("%d",&t);
	init();
	ll ans=0;
	for(int i=0;i<=k;i++)
		ans=(ans+(xs[i]*C[k][i]*f[i])%MOD+MOD)%MOD;
	printf("%lld\n",ans);
	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值