POJ 2398 Toy Storage sort+叉积+二分

http://poj.org/problem?id=2398

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

在这里插入图片描述
We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input
The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input. 

Output
For each box, first provide a header stating “Box” on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.
Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

题目大意:和这道题差不多。只不过输入的 n n n条线段不是有序的,最后对于每一个 t &gt; 0 t&gt;0 t>0的情况要输出 t :   c n t [ t ] t:\ cnt[t] t: cnt[t],其中 t t t表示玩具个数, c n t [ t ] cnt[t] cnt[t]表示玩具个数为 t t t的区域的数量。

思路:跟上面说的那道题差不多,只不过要先对 n n n条线段排序,然后二分+叉积。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;

const double pi=acos(-1.0);//弧度pi
const double eps=1e-8;//精度

struct point
{
    double x,y;
    point(double a=0,double b=0)
    {
        x=a,y=b;
    }
    friend point operator * (point a,double b)
    {
        return point(a.x*b,a.y*b);
    }
    friend point operator * (double a,point b)
    {
        return point(b.x*a,b.y*a);
    }
    point operator - (const point &b)const
    {
        return point(x-b.x,y-b.y);
    }
    point operator + (const point &b)const
    {
        return point(x+b.x,y+b.y);
    }
    point operator / (const double b)const
    {
        return point(x/b,y/b);
    }
    bool operator < (const point &b)const//按坐标排序
    {
        if(fabs(x-b.x)<eps)
            return y<b.y-eps;
        return x<b.x-eps;
    }
    void transxy(double sinb,double cosb)//逆时针旋转b弧度
    {                                      //若顺时针 在传入的sinb前加个-即可
        double tx=x,ty=y;
        x=tx*cosb-ty*sinb;
        y=tx*sinb+ty*cosb;
    }
    void transxy(double b)//逆时针旋转b弧度
    {                     //若顺时针传入-b即可
        double tx=x,ty=y;
        x=tx*cos(b)-ty*sin(b);
        y=tx*sin(b)+ty*cos(b);
    }
    double norm()
    {
        return sqrt(x*x+y*y);
    }
};

inline double dot(point a,point b)//点积
{
    return a.x*b.x+a.y*b.y;
}
inline double cross(point a,point b)//叉积
{
    return a.x*b.y-a.y*b.x;
}

inline double dist(point a,point b)//两点间距离
{
    return (a-b).norm();
}

inline int sgn(double x)
{
    if(fabs(x)<eps)
        return 0;
    if(x>0)
        return 1;
    return -1;
}

typedef point Vector;
const int maxn=1005;

struct node
{
    int ux,lx;
    bool operator <(const node &a)const
    {
        return lx<a.lx;
    }
}a[maxn];
int n,m,ux,uy,lx,ly,x,y;
int L,R,mid;
int ans[maxn],cnt[maxn];

bool check(int i)
{
    Vector v1(a[i].ux-a[i].lx,uy-ly);
    Vector v2(x-a[i].lx,y-ly);
    if(cross(v1,v2)>eps)//v1逆时针转到v2
        return 0;
    return 1;
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(ans,0,sizeof(ans));
        memset(cnt,0,sizeof(cnt));
        scanf("%d%d%d%d%d",&m,&ux,&uy,&lx,&ly);
        for(int i=1;i<=n;i++)
            scanf("%d%d",&a[i].ux,&a[i].lx);
        sort(a+1,a+1+n);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            L=1,R=n;
            while(L<=R)
            {
                mid=(L+R)>>1;
                if(check(mid))
                    L=mid+1;
                else
                    R=mid-1;
            }
            ++ans[R];
        }
        for(int i=0;i<=n;i++)
            ++cnt[ans[i]];
        printf("Box\n");
        for(int i=1;i<=n;i++)
            if(cnt[i])
                printf("%d: %d\n",i,cnt[i]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值