11-散列4 Hashing - Hard Version (30分)

Given a hash table of size N, we can define a hash function . Suppose that the linear probing is used to solve collisions, we can easily obtain the status of the hash table with a given sequence of input numbers.
However, now you are asked to solve the reversed problem: reconstruct the input sequence from the given status of the hash table. Whenever there are multiple choices, the smallest number is always taken.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), which is the size of the hash table. The next line contains N integers, separated by a space. A negative integer represents an empty cell in the hash table. It is guaranteed that all the non-negative integers are distinct in the table.

Output Specification:
For each test case, print a line that contains the input sequence, with the numbers separated by a space. Notice that there must be no extra space at the end of each line.


Sample Input:
11
33 1 13 12 34 38 27 22 32 -1 21
Sample Output:
1 13 12 21 33 34 38 27 22 32


//建立邻接表
//随时将入度变为0的数放入优先队列
//每次出队即输出,队空时结束

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
const int N = 1000;
int num[N], indegree[N];
struct cmp {
	bool operator()(int i, int j) {
		return num[i] > num[j];
	}
};
int main() {
	int i, j, n, m, k, flag = 0;
	scanf("%d", &n);
	vector<vector<int> > g(n);
	priority_queue<int, vector<int>, cmp> q;
	for (i = 0; i < n; i++) 
		scanf("%d", &num[i]);

	for (i = 0; i < n; i++) {
		if (num[i] > 0) {
			k = num[i] % n;
			indegree[i] = (i + n - k) % n;
			if (indegree[i]) {
				for (j = 0; j <= indegree[i]; j++) 
					g[(k + j) % n].push_back(i);
			}
			else q.push(i);
		}
	}

	while (!q.empty()) {
		i = q.top();
		q.pop();
		if (!flag) {
			flag = 1;
			printf("%d", num[i]);
		}
		else printf(" %d", num[i]);
		for (j = 0; j < g[i].size(); j++) {
			if (--indegree[g[i][j]] == 0)
				q.push(g[i][j]);
		}
	}
	return 0;
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值