hdu 3018 Ant Trip 【图论-欧拉路】

                                        Ant Trip
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.
Ant Tony,together with his friends,wants to go through every part of the country.
They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.

Output
For each test case ,output the least groups that needs to form to achieve their goal.

Sample Input
3 3
1 2
2 3
1 3

4 2
1 2
3 4

Sample Output
1
2

Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town.
In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3.
In sample 2,tony and his friends must form two group.

题目大意:在蚂蚁王国有n个城市,城市之间有m条路,托尼和他的朋友想游览每个城市,并且每个城市只去一次,让你算出,想要逛遍所有城市,最少需要几人?

AC代码:

# include <iostream>
# include <cstring>
# include <cstdio>

using namespace std;

# define MAXN 100005

int father[MAXN];
int degree[MAXN];
int nodenum[MAXN];
int odd[MAXN];

int FindRt(int x)
{
    if (-1 == father[x])
    {
        return x;
    }
    else
    {
        return father[x] = FindRt(father[x]);
    }
}

void Unite(int a, int b)
{
    int ta = FindRt(a);
    int tb = FindRt(b);
    if (ta != tb)
    {
        father[ta] = tb;
    }
}

int main(void)
{
    int n, m;
    while (~scanf("%d %d", &n, &m))
    {
        int i;
        memset(father, -1, sizeof(father));
        memset(degree, 0, sizeof(degree));
        memset(nodenum, 0, sizeof(nodenum));
        memset(odd, 0, sizeof(odd));

        for (i = 0; i < m; i++)
        {
            int u, v;
            scanf("%d %d", &u, &v);
            degree[u] ++;
            degree[v] ++;
            Unite(u, v);
        }

        for (i = 1; i <= n; i++)
        {
            nodenum[FindRt(i)] ++;  //计算一个连通分量中的节点的个数
            if (1 == degree[i] % 2) //如果为奇数度
            {
                odd[FindRt(i)]++; //父节点的奇数度加一
            }
        }
        int res = 0;
        for (i = 1; i <= n; i++)
        {
            if (nodenum[i] <= 1)
            {
                continue;
            }
            if (odd[i] == 0)  //如果不是奇数度 则只需一人
            {
                res++;
            }
            else if (odd[i] > 0) //如果是奇数度,则为奇数度/2 人
            {
                res += (odd[i] / 2);
            }
        }

        printf("%d\n", res);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值