poj 2337 Catenyms 【图论-欧拉图-按字典序输出路径】

                                        Catenyms
                        Time Limit: 1000MS      Memory Limit: 65536K

Description
A catenym is a pair of words separated by a period such that the last letter of the first word is the same as the last letter of the second. For example, the following are catenyms:
dog.gopher

gopher.rat

rat.tiger

aloha.aloha

arachnid.dog

A compound catenym is a sequence of three or more words separated by periods such that each adjacent pair of words forms a catenym. For example,

aloha.aloha.arachnid.dog.gopher.rat.tiger

Given a dictionary of lower case words, you are to find a compound catenym that contains each of the words exactly once.

Input
The first line of standard input contains t, the number of test cases. Each test case begins with 3 <= n <= 1000 - the number of words in the dictionary. n distinct dictionary words follow; each word is a string of between 1 and 20 lowercase letters on a line by itself.

Output
For each test case, output a line giving the lexicographically least compound catenym that contains each dictionary word exactly once. Output “*” if there is no solution.

Sample Input
2
6
aloha
arachnid
dog
gopher
rat
tiger
3
oak
maple
elm

Sample Output
aloha.arachnid.dog.gopher.rat.tiger


题目大意:和poj1386很相似,但是多出了要按照字典序输出排成的句子。

AC代码:

//kuangbin的模板
# include <iostream>
# include <cstring>
# include <cstdio>
# include <cmath>
# include <string>
# include <algorithm>

using namespace std;

# define MAXN 1005
# define MAXM 5005

struct Edge
{
    int to,next;
    int index;
    bool flag;
}edge[MAXM];

int tot;
int cnt;
int head[MAXN];
string str[MAXN];
int in[MAXN];
int out[MAXN];
int ans[MAXM];

void Init()
{
    tot = 0;
    memset(head,-1,sizeof(head));
}

void Addedge(int u,int v,int index)
{
    edge[tot].to = v;
    edge[tot].next = head[u];
    edge[tot].index = index;
    edge[tot].flag = false;
    head[u] = tot++;
}

void dfs(int u)
{
    for(int i = head[u] ;i != -1;i = edge[i].next)
    {
        if(!edge[i].flag)
        {
            edge[i].flag = true;
            dfs(edge[i].to);
            ans[cnt++] = edge[i].index;
        }
    }
}

int main()
{
    int T,n;
    cin >> T;
    while(T--)
    {
        cin >> n;
        int i;
        for(i = 0;i < n;i++)
        {
            cin >> str[i];
        }
        sort(str,str+n);//要输出字典序最小的解,先按照字典序排序
        Init();
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        int start = 100;

        for(i = n-1;i >= 0;i--)//字典序大的先加入
        {
            int u = str[i][0] - 'a';
            int v = str[i][str[i].length() - 1] - 'a';
            Addedge(u,v,i);
            out[u]++;
            in[v]++;
            if(u < start)
            {
                start = u;
            }
            if(v < start)
            {
                start = v;
            }
        }

        //判断图是否具有欧拉通路
        int cc1 = 0, cc2 = 0;
        for(i = 0;i < 26;i++) 
        {
            if(out[i] - in[i] == 1)
            {
                cc1++;
                start = i;//如果有一个出度比入度大1的点,就从这个点出发,否则从最小的点出发
            }
            else if(out[i] - in[i] == -1)
            {
                cc2++;
            }
            else if(out[i] - in[i] != 0)
            {
                cc1 = 3;
            }
        }
        if(! ( (cc1 == 0 && cc2 == 0) || (cc1 == 1 && cc2 == 1) ))
        {
            cout << "***" << endl;
            continue;
        }

        cnt = 0;
        dfs(start);
        if(cnt != n)//当图不连通
        {
            cout << "***" << endl;
            continue;
        }

        for(i = cnt-1; i >= 0;i--)
        {
            cout<<str[ans[i]];
            if(i > 0)
            {
                cout << ".";
            }
        }
        cout << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值