Crawling in process... Crawling failed Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 37 24 35 220 325 1824 1515 10-1 -1
Sample Output
13.33331.500
思路
代码
#include <stdio.h>
#include <algorithm>
using namespace std;
struct p{
int a,b;
double c;
}s[1000];
int cmp(p u,p v)
{
return u.c>v.c;
}
int main()
{
int x,y,i,sum=0,hu=0,m=0;
double w;
while(scanf("%d%d",&x,&y)!=EOF&&(x!=-1&&y!=-1))
{
for(i=0;i<y;i++)
{
scanf("%d%d",&s[i].a,&s[i].b);
s[i].c=(double)s[i].a/(double)s[i].b;
}
sort(s,s+y,cmp);
for(i=0;i<y;i++)
{
sum+=s[i].b;
if(sum<=x)
{
m+=s[i].a;
hu+=s[i].b;
}
else
{
sum=x-hu;
break;
}
}
w=(double)s[i].a*((double)sum/s[i].b);
printf("%.3lf\n",w+m);
}
return 0;
}