hdu1829并查集

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5567    Accepted Submission(s): 1828


Problem Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
思路:对于每一对可交配的a,b,设立一个集合set[i]表示i可以交配的元素,将b和set[a]放到一个集合表示b和set[a]是同一种性别,都是可以和a交配,同理将set[b],a放到 一个集合,则只要判断a,b是否在同一个集合,若a,b在同一个集合表示他们能交配并且是同种性别,则他们是同性恋
 
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=2000+10;
int father[MAX],rank[MAX],set[MAX];
bool mark;

void makeset(int num){
	for(int i=1;i<=num;++i){
		father[i]=set[i]=i;
		rank[i]=1;
	}
}

int findset(int v){
	if(v != father[v])father[v]=findset(father[v]);
	return father[v];
}

void Union(int x,int y){
	int a=findset(x);
	int b=findset(y);
	if(a == b)return;
	if(rank[a]>rank[b]){
		father[b]=a;
		rank[a]+=rank[b];
	}
	else{
		father[a]=b;
		rank[b]+=rank[a];
	}
}

int main(){
	int t,n,m,a,b,num=0;
	cin>>t;
	while(t--){
		cin>>n>>m;
		makeset(n);
		mark=true;
		for(int i=0;i<m;++i){
			scanf("%d%d",&a,&b);
			if(findset(a) == findset(b))mark=false;
			if(mark){
				if(set[a] == a)set[a]=b;
				else Union(set[a],b);
				if(set[b] == b)set[b]=a;
				else Union(set[b],a);
			}
		}
		cout<<"Scenario #"<<++num<<":\n";
		if(mark)cout<<"No suspicious bugs found!"<<endl<<endl;
		else cout<<"Suspicious bugs found!"<<endl<<endl;
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值