hdu2125之dp

Local area network

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 410    Accepted Submission(s): 101


Problem Description
A local area network (LAN) supplies networking capability to a group of computers in close proximity to each other such as in an office building, a school, or a home. A LAN is useful for sharing resources like files, printers, games or other applications. A LAN in turn often connects to other LANs, and to the Internet or other WAN. 
In this contest, everybody is connecting with each others like the following figure.



The contest’s network was built as N rows and M columns, your computer locate at (0, 0) and the judger’s computer locate at  (m-1, n-1) The code you submit would only transfer to up or right smoothly. It doesn’t matter if some accidents happened. Could you tell me how many ways from your computer to judger when a data wire was broken?

 

Input
There are multiple cases. Every case contains two integers in the first line, N, M (3<=N+M<=40). Second line contains four integers X1, Y1, X2, Y2 (0<=X1, X2<M, 0<=Y1, Y2<N, |X1+Y1-X2-Y2|=1), meaning the broken wire position.
 

Output
Print the answer in one line.
 

Sample Input
  
  
3 3 0 0 1 0
 

Sample Output
  
  
3
注意题目给的图,行和列别弄错了

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=40+10;
int dp[MAX][MAX];
bool mark[MAX][MAX];

int main(){
	int n,m,x1,y1,x2,y2;
	while(cin>>n>>m){
		memset(mark,false,sizeof mark);
		cin>>x1>>y1>>x2>>y2;
		dp[0][1]=1;
		mark[y1+1][x1+1]=mark[y2+1][x2+1]=true;
		for(int i=1;i<=n;++i){
			for(int j=1;j<=m;++j){
				dp[i][j]=dp[i-1][j]+dp[i][j-1];
				if(mark[i][j] && mark[i-1][j])dp[i][j]-=dp[i-1][j];
				if(mark[i][j] && mark[i][j-1])dp[i][j]-=dp[i][j-1];
			}
		}
		cout<<dp[n][m]<<endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值