筛选素数法(HDU 2710)

Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5645    Accepted Submission(s): 1829


Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
 

Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line
 

Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
 

Sample Input
  
  
4 36 38 40 42
 

Sample Output
  
  
38

题意:首先给出N,在接下来的N行输入数字,每个数字都有它的因子,求这N个数的最大的素数的因子,如果素数因子有相同的,则输出最前面的那个

数据量很大,传统的做法已经不行了,会超时,于是乎找到了一种素数筛选的代码

本题中注意1也是素数

#include <iostream>
#include <cmath>
#include <string>
using namespace std;

int main()
{
	int i,j,k;
	int n,m,t;
	int cnt,num[20001]={0,1};

	for(i=2;i<20001;i++)
	{
		if(num[i]==0)
		{
			for(j=i;j<20001;j+=i)
				num[j] = i;
		}
	}

	while(cin>>n)
	{
		cnt=-1;
		while(n--)
		{
			cin>>m;
			if(num[m]>cnt)
			{
				cnt = num[m];
				k = m;
			}
		}
		cout<<k<<endl;
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值