素数筛选:HDU2710-Max Factor

Max Factor

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

Input

  • Line 1: A single integer, N

  • Lines 2..N+1: The serial numbers to be tested, one per line

Output

  • Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

Sample Input

4
36
38
40
42

Sample Output

38


解题心得:
  1. 就是一个简单的素数筛选,然后暴力找一下因子,判断记录就可以了。没有什么好说的。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 2e4+100;
bool pre_num[maxn];

//先吧素数给筛选出来
void get_pre_num()
{
    for(int i=2; i<=sqrt(maxn); i++)
    {
        if(pre_num[i])
            continue;
        for(int j=i*i; j<maxn; j+=i)
            pre_num[j] = true;
    }
    pre_num[1] = pre_num[0] = true;
}

int main()
{
    get_pre_num();
    int n;
    while(scanf("%d",&n) != EOF)
    {
        int Max = 0,pos = 1;
        for(int i=0; i<n; i++)
        {
            int now;
            scanf("%d",&now);
            int N = now;
            for(int j=2; j<=sqrt(now); j++)
            {
                if(now%j == 0)//暴力找因子
                {
                    if(!pre_num[j])
                    {
                        if(j > Max)//记录一下就可以了
                        {
                            Max = j;
                            pos = N;
                        }
                    }
                    while(now%j == 0)
                        now /= j;
                }
            }
            if(now > 1 && !pre_num[now])//别忘了最后还剩下一个
            {
                if(now > Max)
                {
                    Max = now;
                    pos = N;
                }
            }
        }
        printf("%d\n",pos);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值