A+B for Input-Output Practice (V)

Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15

#include<stdio.h>
int main()
{
    int N,M,i,j,x,sum;
    while(scanf("%d",&N)!=EOF)//测试多组数据
    {
        for(i=0; i<N; i++)//N是行数
        {
            sum=0;//每一次循环sum置零
            scanf("%d",&M);
            for(j=0; j<M; j++)//M是每一行的整数个数
            {
                scanf("%d",&x);
                sum+=x;
            }
            printf("%d\n",sum);
        }
    }
    return 0;
}

注意:用两个变量 i和j 控制嵌套for循环

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值