hdu2609(hash+STL+字典树)

How many

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1040    Accepted Submission(s): 406


Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.
 

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').
 

Output
For each test case output a integer , how many different necklaces.
 

Sample Input
  
  
4 0110 1100 1001 0011 4 1010 0101 1000 0001
 

Sample Output
  
  
1 2
 

Author
yifenfei
 

Source
 

Recommend
yifenfei
 
本题要求不同构的字符串的个数。
两个字符串同构是指其中一个可以仅经过循环移位得到另外一个。而同构可以用最小表示法来解决。
每读入一个字符串,就找到它的最小表示形式;在判断该最小表示形式是否已经出现过:若没有则计数器加1,并将该最小表示形式存储起来;若有则直接处理下一个。最终计数器即为所求。判断是否出现过可以hash表,但字符串的hash表不好维护,可以考虑用字典树判重或用STL中的set容器。
#include<iostream>
#include<set>
#include<string>
using namespace std;


//返回母串的最小子串的起始位置
int minpresent(string &str)
{
	int i,j,k,len=str.size();
	i=0,j=1,k=0;
	while(i<len&&j<len&&k<len)
	{
		if(str[(i+k)%len]==str[(j+k)%len])
			k++;
		else 
		{
			if(str[(i+k)%len]>str[(j+k)%len])
			i=i+k+1;
		    else 
			j=j+k+1;
			if(i==j)j++;
			k=0;
		}
	}
	return ++i<++j?i:j;
}


int main()
{
	int n,i,Minid,ans;
	bool flag;
	string tmp,str;
	set<string>Set;
	while(~scanf("%d",&n))
	{
		Set.clear();
		ans=0;
		for(i=0;i<n;i++)
		{
			cin>>tmp;
			Minid=minpresent(tmp)-1;
			str.assign(tmp,Minid,tmp.size()-Minid);
			if(Minid)str.append(tmp,0,Minid);
			if(!Set.count(str))
			{
				ans++;
				Set.insert(str);
			}
		}

		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值