hdu4310(贪心)

Hero

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2205    Accepted Submission(s): 989


Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 

Output
Output one line for each test, indicates the minimum HP loss.
 

Sample Input
  
  
1 10 2 2 100 1 1 100
 

Sample Output
  
  
20 201
 

Author
TJU
 

Source
 

Recommend
zhuyuanchen520
 


本题给出n个敌人,每个敌人有一个攻击值和血量,你每次只能选择一个人攻击且只能耗他的一滴血,与此同时其他活着的敌人会攻击你,你的血量损失为所有活着的敌人的和。

仔细一想,本题是个贪心题,关键在于找对贪心策略。

本题较为合适的策略大约有以下几种:

 1.每次选择当前攻击值最大的攻击他,可以保证攻击值的和减少得最大

2.每次选择当前血量最少的攻击他,可以保证攻击值的和减少得最快

3.每次选择当前攻击值/血量比最小的攻击他,可以保证攻击值的和减少得既快又大。

 

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

const int MAXN=1000+10;
struct node
{
	int HP,DPS;
}Per[MAXN];

bool cmp(node a,node b)
{
	return a.DPS*b.HP>b.DPS*a.HP;
}

int main()
{
	int n,i,sum,num;
	while(~scanf("%d",&n))
	{
		for(i=0;i<n;i++)
			scanf("%d%d",&Per[i].DPS,&Per[i].HP);
		sort(Per,Per+n,cmp);
		sum=0,num=0;
		for(i=0;i<n;i++)
		{
			num+=Per[i].HP;
			sum+=(Per[i].DPS*num);
		}
		printf("%d\n",sum);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值