HDU 4310

      Hero

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1263 Accepted Submission(s): 634

Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero’s HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output
Output one line for each test, indicates the minimum HP loss.

Sample Input
1
10 2
2
100 1
1 100

Sample Output
20
201

题意:Dota游戏中有n组敌人,每次攻击一个敌人会使这个敌人的HP减1,
但是同时你的英雄的DPS(开始是是无穷的)的值会减少,减少值为所有在当前回合仍存活的敌人的DPS总和,若敌人的HP<=0会在这一回合结束后死亡。要求将所有的敌人都消灭后你的英雄的DPS剩余的最多,即求耗费的DPS的值最少。

思路:用贪心解决。血量少攻击高的要先消灭(注意:不是优先攻击血量高的是D/H高的),所以以HP/DPS作为参数排序,即将所有的敌人根据DPS/HP从大到小排序,如果相等,则按HP从小到大排序。

并且写代码时有精度问题。

代码为:

#include<iostream>
#include<string.h>
#include<algorithm>
#include<cstdio>
using namespace std;
struct stuff
{
    double D,H;
    //使用double型,因为在cmp的D/H进行比较时int精度不够。
};
bool cmp(const stuff &a,const stuff &b)
{
    return a.D/a.H>b.D/b.H;
}
int main()
{
    int n;
    int ans,sum;
    //long long sum,ans; 
    //使用long long 和 int 都可以
    stuff a[25];
    while(scanf("%d",&n)!=EOF)
    {
        sum=0,ans=0;
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&a[i].D,&a[i].H);
            //使用double型,因为在cmp的D/H进行比较时int精度不够。
            ans+=a[i].H;
        }
        sort(a,a+n,cmp);
       // for(int i=0;i<n;i++)
           // cout<<a[i].D<<endl;
        while(ans>0)
        {
            int ia=-1;
            for(int i=0;i<n;i++)
            {
                if(a[i].H==0)
                    ia=i;
                else
                    sum+=a[i].D;
            }
            ans--;
            a[ia+1].H--;
         //   cout<<ia<<"   "<<a[ia].H<<endl;
         }
        cout<<sum<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是hdu4310的Java解法: ```java import java.util.*; import java.io.*; public class Main { static int MAXN = 100010; static int MAXM = 200010; static int INF = 0x3f3f3f3f; static int n, m, s, t, cnt; static int[] head = new int[MAXN]; static int[] dis = new int[MAXN]; static boolean[] vis = new boolean[MAXN]; static int[] pre = new int[MAXN]; static int[] cur = new int[MAXN]; static class Edge { int to, next, cap, flow, cost; public Edge(int to, int next, int cap, int flow, int cost) { this.to = to; this.next = next; this.cap = cap; this.flow = flow; this.cost = cost; } } static Edge[] edge = new Edge[MAXM]; static void addEdge(int u, int v, int cap, int flow, int cost) { edge[cnt] = new Edge(v, head[u], cap, flow, cost); head[u] = cnt++; edge[cnt] = new Edge(u, head[v], 0, 0, -cost); head[v] = cnt++; } static boolean spfa() { Arrays.fill(dis, INF); Arrays.fill(vis, false); Queue<Integer> q = new LinkedList<>(); q.offer(s); dis[s] = 0; vis[s] = true; while (!q.isEmpty()) { int u = q.poll(); vis[u] = false; for (int i = head[u]; i != -1; i = edge[i].next) { int v = edge[i].to; if (edge[i].cap > edge[i].flow && dis[v] > dis[u] + edge[i].cost) { dis[v] = dis[u] + edge[i].cost; pre[v] = u; cur[v] = i; if (!vis[v]) { vis[v] = true; q.offer(v); } } } } return dis[t] != INF; } static int[] MCMF(int s, int t) { int flow = 0, cost = 0; while (spfa()) { int f = INF; for (int u = t; u != s; u = pre[u]) { f = Math.min(f, edge[cur[u]].cap - edge[cur[u]].flow); } for (int u = t; u != s; u = pre[u]) { edge[cur[u]].flow += f; edge[cur[u] ^ 1].flow -= f; cost += edge[cur[u]].cost * f; } flow += f; } return new int[]{flow, cost}; } public static void main(String[] args) { Scanner in = new Scanner(new BufferedReader(new InputStreamReader(System.in))); int T = in.nextInt(); for (int cas = 1; cas <= T; cas++) { n = in.nextInt(); m = in.nextInt(); s = 0; t = n + m + 1; cnt = 0; Arrays.fill(head, -1); for (int i = 1; i <= n; i++) { int c = in.nextInt(); addEdge(s, i, c, 0, 0); } for (int i = 1; i <= m; i++) { int c = in.nextInt(); addEdge(i + n, t, c, 0, 0); } for (int i = 1; i <= n; i++) { for (int j = 1; j <= m; j++) { int c = in.nextInt(); addEdge(i, j + n, INF, 0, c); } } int[] ans = MCMF(s, t); System.out.printf("Case #%d: %d\n", cas, ans[1]); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值