hdu2276(矩阵的快速幂)

Kiki & Little Kiki 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1711    Accepted Submission(s): 874


Problem Description
There are n lights in a circle numbered from 1 to n. The left of light 1 is light n, and the left of light k (1< k<= n) is the light k-1.At time of 0, some of them turn on, and others turn off.
Change the state of light i (if it's on, turn off it; if it is not on, turn on it) at t+1 second (t >= 0), if the left of light i is on !!!Given the initiation state, please find all lights’ state after M second. (2<= n <= 100, 1<= M<= 10^8)

 

Input
The input contains one or more data sets. The first line of each data set is an integer m indicate the time, the second line will be a string T, only contains '0' and '1' , and its length n will not exceed 100. It means all lights in the circle from 1 to n.
If the ith character of T is '1', it means the light i is on, otherwise the light is off.

 

Output
For each data set, output all lights' state at m seconds in one line. It only contains character '0' and '1.
 

Sample Input
  
  
1 0101111 10 100000001
 

Sample Output
  
  
1111000 001000010
 

Source
 

Recommend
lcy
        本题所有的灯构成一个环,某时刻如果某盏灯的左边为on,则改变该灯的状态,问一段时间过后所有灯的状态。
        本题题意不难理解,时间过大,不能直接模拟。经过观察发现本题可以用矩阵的快速幂。分析见代码。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN=100+10;
char str[MAXN];
struct matrix
{
	int len;
	int a[MAXN][MAXN];
}Origin,res;
/*********************************
origin初始化为
   1  0  0 …… 0  0  1
   1  1  0 …… 0  0  0
   0  1  1 …… 0  0  0
   0  0  1 …… 0  0  0
   ………………………
   0  0  0 …… 1  1  0
   0  0  0 …… 0  1  1

res初始化为str的转置形式,其他位置填0
*********************************/

void init(int len)
{
	int i,j;
	memset(Origin.a,0,sizeof(Origin.a));
	for(i=0;i<len;i++)
	{
		for(j=0;j<len;j++)
		{
			if(i!=0)
			{
				if(j==i||j==i-1)Origin.a[i][j]=1;
				else Origin.a[i][j]=0;
			}
			else 
			{
				if(j==0||j==len-1)Origin.a[i][j]=1;
				else Origin.a[i][j]=0;
			}
		}
	}
	Origin.len=len;

	memset(res.a,0,sizeof(res.a));
	res.len=len;
	for(i=0;i<len;i++)
		res.a[i][0]=str[i]-'0';
}


void print(int len)
{
	int i,j;

	printf("*******Origin*******\n");
	for(i=0;i<len;i++)
	{
		for(j=0;j<len;j++)
			printf("%d ",Origin.a[i][j]);
		printf("\n");
	}
	printf("*********res****\n");
	for(i=0;i<len;i++)
	{
		for(j=0;j<len;j++)
			printf("%d ",res.a[i][j]);
		printf("\n");
	}
}

matrix MatrixMultiple(matrix &ori,matrix &ans)
{
	matrix ret;
	ret.len=ori.len;
	int i,j,k;
	memset(ret.a,0,sizeof(ret.a));
	for(i=0;i<ori.len;i++)
	{
		for(j=0;j<ori.len;j++)
		{
			for(k=0;k<ans.len;k++)
			{
				ret.a[i][j]+=(ori.a[i][k]*ans.a[k][j]);
			}
			ret.a[i][j]%=2;
		}
	}
	return ret;
}

void MatrixPow(int t)
{
	while(t)
	{
		if(t&1)
			res=MatrixMultiple(Origin,res);
		Origin=MatrixMultiple(Origin,Origin);
		t=t>>1;
	}
}

int main()
{
	int t,len,i;
	while(~scanf("%d",&t))
	{
		scanf("%s",str);
		len=strlen(str);
		//printf("len=%d  str=%s\n",len,str);

		init(len);
		//print(len);

		MatrixPow(t);

		for(i=0;i<len;i++)
			printf("%d",res.a[i][0]);
		printf("\n");
		/*************************************
		直接模拟超时代吗
		k=0;
		//	printf("t=%d  str=%s\n",t,str[k]);
		for(i=1;i<=t;i++)
		{
		for(j=0;j<len;j++)
		{
		//printf("***\n");
		if((j>0&&str[k][j-1]=='1')||(j==0&&str[k][len-1]=='1'))
		str[k^1][j]=(str[k][j]=='1'?'0':'1');
		else str[k^1][j]=str[k][j];

		}
		str[k^1][len]=0;
		k=k^1;
		//printf("t=%d  str=%s\n",t,str[k]);
		}
		*****************************************/
		//printf("%s\n",str[k]);
	}
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值