poj2352(线段树或树状数组)

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26238 Accepted: 11448

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
 
题目是在引导我们用线段树或树状数组,因为在反复地进行加与查询操作
注意此题不能先求出lowbit[],这样可能超时
这告诉我们即使在时间复杂度相同的情况下,运行时间可能存在很大差别。
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
const int MAX=32000+10;

int n;
//int lowbit[MAX];
int C[MAX];
int ans[15002];

int lowbit(int i)
{
	return i&(-i);
}

int QuerySum(int p)
//查询原数组中下标1-p的元素的和 
{ 
   int nSum = 0; 
   while( p > 0 ) 
   {  
      nSum += C[p]; 
      p -= lowbit(p); 
   } 
    return nSum; 
} 

void Modify( int p,int val) 
//原数组中下表为p的元素+val,导致C[]数组中部分元素值的改变
{ 
    while( p <=MAX) 
   { 
      C[p] += val; 
      p += lowbit(p); 
    } 
} 

int main()
{
	int i;
	int x,y;
	scanf("%d",&n);
		memset(C,0,sizeof(C));
		memset(ans,0,sizeof(ans));
	//	for(i=1;i<=n;i++)
	//		lowbit[i]=i&(-i);
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&x,&y);
			ans[QuerySum(x+1)]++;
			Modify( x+1,1) ;
		}
		for(i=0;i<=n-1;i++)
			printf("%d\n",ans[i]);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值