POJ_2352 Stars

Stars

链接

POJ_2352 Stars

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
图例

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
大意:
天空中有一些星星,这些星星都在不同的位置,每个星星有个坐标。如果一个星星的左下方(包含正左和正下)有k颗星星,就说这颗星星是k级的。
给定星星的位置,输出各级星星的数目。

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
大意:
给定n个点,定义每个点的等级是在该点左下方(含相等)的点的数目,试统计每个等级有多少个点。每个点按照y坐标升序排列,y坐标相同的按照x坐标升序排列。(n<=15000,0<=x,y<=32000)

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

思路

  1. 由于后输入的点的y坐标一定小于先输入的点的y坐标,所以后输入的点必定在先输入的点的上方。这使得我们在统计星星的个数时不需要考虑y坐标的影响。
  2. 每输入一个点,就将树状数组中对应的x坐标的位置+1,表示该x坐标处增加一个点。同时做一次统计,统计处该点外x坐标小于等于该点的点一共有几个,这个统计出来的数就是该点的等级。
  3. 点的坐标会有0,但树状数组不能有0,所以每个输入的x坐标要+1之后才能做运算。

代码

#include<algorithm>
#include<cstdio>
using namespace std;
const int m=32000+1;
int n,x,y,a[m+1],c[m+1],s[m+1];
int lb(int i)
{
	return i&(-i);
}
void add(int i)
{
	while(i<=m)
	{
		a[i]++;
		i+=lb(i);
	}
}
int sum(int i)
{
	int cou=0;
	while(i>0)
	{
		cou+=a[i];
		i-=lb(i);
	}
	return cou;
}
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d",&x,&y);
		add(x+1);//加入树状数组并修改树状数组
		c[sum(x+1)-1]++;//计算该点的等级(sum(x+1)-1)并记录
	}
	for(int i=0;i<n;i++)
		printf("%d\n",c[i]);
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值