hdu2458(二分图+最大独立数+匈牙利算法)

Kindergarten

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 490    Accepted Submission(s): 282


Problem Description
In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
 

Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.
 

Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
 

Sample Input
  
  
2 3 3 1 1 1 2 2 3 2 3 5 1 1 1 2 2 1 2 2 2 3 0 0 0
 

Sample Output
  
  
Case 1: 3 Case 2: 4
 
本题要求相互认识的人的最大个数,即求最大独立团的个数(即补图的最大独立数),有最大独立数=顶点数-最大点覆盖数,最大点覆盖数=最大匹配,最大匹配可以运用匈牙利算法求解
 
#include<iostream>
#include<cstdio>
using namespace std;

const int MAXN=200+10;
int G,B;//u,v数目
int g[MAXN][MAXN];
int linker[MAXN];
bool visited[MAXN];


bool dfs(int u)//从左边开始找增广路径
{
    int v;
    for(v=1;v<=B;v++)//这个顶点编号从0开始,若要从1开始需要修改
      if(g[u][v]&&!visited[v])
      {
          visited[v]=true;
          if(linker[v]==-1||dfs(linker[v]))
          {//找增广路,反向
              linker[v]=u;
              return true;
          }
      }
    return false;//这个不要忘了,经常忘记这句
}

int hungary()
{
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=1;u<=G;u++)
    {
        memset(visited,0,sizeof(visited));
        if(dfs(u)) res++;
    }
    return res;
}



int main()
{
	int M,i,a,b,j;
	int tag=1;
	while(scanf("%d%d%d",&G,&B,&M))
	{
		if(0==G&&0==B&&0==M)
			break;
		memset(g,1,sizeof(g));

		for(i=0;i<M;i++)
		{
			scanf("%d%d",&a,&b);
			g[a][b]=0;
		}

		printf("Case %d: %d\n",tag++,G+B-hungary());
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值