hdu3853(概率DP)

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 1019    Accepted Submission(s): 415


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 


 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 


 

Sample Input
  
  
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 


 

Sample Output
  
  
6.000
 


 

Source
 


 

Recommend
chenyongfu
有一个人被困在一个 R*C(2<=R,C<=1000) 的迷宫中,起初他在 (1,1) 这个点,迷宫的出口是 (R,C)。在迷宫的每一个格子中,他能花费 2 个魔法值开启传送通道。假设他在 (x,y) 这个格子中,开启传送通道之后,有 p_lift[i][j] 的概率被送到 (x,y+1),有 p_down[i][j] 的概率被送到 (x+1,y),有 p_loop[i][j] 的概率被送到 (x,y)。问他到出口需要花费的魔法值的期望是多少。
设dp[i][j]表示(i,j)到达(R,C)所花的魔法值。根据题目的状态转移方程
    f[i][j]=2+p_lift[i][j]*f[i][j+1]+p_loop[i][j]*f[i][j]+p_down[i][j]*f[i+1][j]
运用这个方程就能很好的解决题目所述的问题 。这是我的第一道概率DP题,以后的话功夫在这上面。
 
#include<iostream>
#include<cstdio>
#include<cmath>
#include <cstring>

using namespace std;

double p[3][1005][1005];
double dp[1005][1005];
bool visited[1005][1005];
int R, C;

double Solve(int x, int y)
{
    if(x==R && y==C) return 0;
    if(x>R || y>C) return 0;
    if(visited[x][y]) return dp[x][y];
    if(abs(p[0][x][y]-1)<1e-6)
    {
        visited[x][y]=1;
        return dp[x][y]=0;
    }
    visited[x][y]=1;
    return dp[x][y]=(2+p[1][x][y]*Solve(x, y+1)+p[2][x][y]*Solve(x+1, y))/(1-p[0][x][y]);
}

int main()
{
    while(scanf("%d%d", &R, &C)!=EOF)
    {
        for(int i=1; i<=R; i++)
            for(int j=1; j<=C; j++)
                scanf("%lf%lf%lf", &p[0][i][j], &p[1][i][j], &p[2][i][j]);
        memset(dp, 0, sizeof(dp));
        memset(visited, 0, sizeof(visited));
        printf("%.3lf\n", Solve(1, 1));
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值