[ACM] hdu 3853 LOOPS (概率DP,递推)

286 篇文章 140 订阅
14 篇文章 0 订阅

LOOPS



Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input
  
  
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output
  
  
6.000
 

Source
题意为:

有R*C的迷宫,左上角(1,1)是入口,(R,C)是出口,对于每个格子,有三种选择,停留在本格,向下走一格,向右走一格,每走一格需要消耗2个魔法值,题目中给出每个格子的这三种选择的概率,问从入口到出口所消耗的平均魔法值数。

逆向递推: dp[R][C]=0;    dp[i][j]指的是当前格子到终点所需要的平均魔法值.

p0[i][j]代表当前格子下一步停留在本格子自身的概率

p1[i][j]代表下一步向右走的概率

p2[i][j]代表下一步向左走的概率

那么 有  dp[i][j]= p0[i][j] * dp[i][j] + p1[i][j]*dp[i][j+1] +p2[i][j]*dp[i+1][j] +2 

       即    dp[i][j]= (p1[i][j]*dp[i][j+1]+p2[i][j]*dp[i+1][j] +2 )/ (1-p0[i][j]);

代码:

#include <iostream>
#include <stdio.h>
#include <cmath>
#include <iomanip>
#include <string.h>
using namespace std;
const int maxn=1010;
const double eps=1e-6;
double dp[maxn][maxn];
double p0[maxn][maxn];
double p1[maxn][maxn];
double p2[maxn][maxn];
int r,c;


int main()
{
    while(cin>>r>>c)
    {
        for(int i=1;i<=r;i++)
            for(int j=1;j<=c;j++)
            scanf("%lf%lf%lf",&p0[i][j],&p1[i][j],&p2[i][j]);
        for(int i=r;i>=1;i--)
            for(int j=c;j>=1;j--)
        {
            if(fabs(1-p0[i][j])<=eps)//有些格子只能在自己位置,不能移动
                dp[i][j]=0;
            else
                dp[i][j]=((p1[i][j]*dp[i][j+1]+p2[i][j]*dp[i+1][j])+2)/(1-p0[i][j]);
        }
        cout<<setiosflags(ios::fixed)<<setprecision(3)<<dp[1][1]<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值