POJ 3041 Asteroids(匈牙利算法)

原题链接:http://poj.org/problem?id=3041
Time Limit: 1000MS Memory Limit: 65536K

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
    Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:

The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold

解题思路

题意是最少选择多少行或者列,使其可以覆盖图中所有的X。可以以此构造出二分图,第一部分的点集看作是横坐标,第二部分的点集看作是纵坐标(例如(x,y)的位置有X,那就从第一部分序号为x的点到第二部分序号为y的点连一条边)。原题就可以转化为至少选择几个点,可以选到所有的边(如果选中了某个点,那么和这个点相连的边都看作是被选中),也就是二分图的最大匹配问题,使用匈牙利算法解决。(后附算法模板)

AC代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<string>
#include<queue>
#include<sstream>
#include<list>
#include<stack>
#define ll long long
#define ull unsigned long long
#define rep(i,a,b) for (int i=(a),_ed=(b);i<=_ed;i++)
#define rrep(i,a,b) for(int i=(a),_ed=(b);i>=_ed;i--)
#define fil(a,b) memset((a),(b),sizeof(a))
#define cl(a) fil(a,0)
#define PI 3.1415927
#define inf 0x3f3f3f3f
template<typename N>N gcd(N a, N b) { return b ? gcd(b, a%b) : a; }
using namespace std;
int g[600][600];
int linker[1005];
bool used[1005];
int un,vn;
bool dfs(int u)
{
    int v;
    for (v = 1;v <= vn;v++)
    {
        if (g[u][v] && !used[v])
        {
            used[v] = true;
            if (linker[v] == -1 || dfs(linker[v]))
            {
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}
int main(void)
{
    int vnum;
    while (cin >> un >>vnum )
    {
        vn = un;
        cl(g);
        rep(i, 1, vnum)
        {
            int temp1, temp2;
            cin >> temp1 >> temp2;
            g[temp1][temp2] = 1;

        }


        int res = 0;
        int u;
        memset(linker, -1, sizeof(linker));
        for (u = 1;u<=un;u++)
        {
            memset(used, 0, sizeof(used));
            if (dfs(u))  res++;
        }
        cout << res << endl;
    }
    return 0;
}

匈牙利算法模板(kuangbin)

const int MAXN=1000;
int uN,vN;  //u,v数目
int g[MAXN][MAXN];//编号是0~n-1的 
int linker[MAXN];
bool used[MAXN];
bool dfs(int u)
{
    int v;
    for(v=0;v<vN;v++)
        if(g[u][v]&&!used[v])
        {
            used[v]=true;
            if(linker[v]==-1||dfs(linker[v]))
            {
                linker[v]=u;
                return true;
            }    
        }  
    return false;  
}    
int hungary()
{
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=0;u<uN;u++)
    {
        memset(used,0,sizeof(used));
        if(dfs(u))  res++;
    } 
    return res;   
}    
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值