HDU 1026 Ignatius and the Princess I(BFS)

原题链接

Problem Description

The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166’s castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166’s room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input

The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output

For each test case, you should output “God please help our poor hero.” if Ignatius can’t reach the target position, or you should output “It takes n seconds to reach the target position, let me show you the way.”(n is the minimum seconds), and tell our hero the whole path. Output a line contains “FINISH” after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input

5 6
.XX.1.
..X.2.
2…X.
…XX.
XXXXX.
5 6
.XX.1.
..X.2.
2…X.
…XX.
XXXXX1
5 6
.XX…
..XX1.
2…X.
…XX.
XXXXX.

Sample Output

It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH

题目大意

要从地图的左上角走到右下角,’.’为可走的点,数字代表通过这个点需要耗费的时间。

解题思路

运用bfs进行搜索,在搜索的过程中存储路径,最后递归输出。

AC代码

#include<bits/stdc++.h>
#define ll long long
#define rep(i,a,b) for (int i=(a),_ed=(b);i<=_ed;i++)
#define fil(a,b) memset((a),(b),sizeof(a))
#define cl(a) fil(a,0)
#define PI 3.1415927
#define inf 0x3f3f3f3f
using namespace std;
int pt;
struct node
{
    int x;
    int y;
    int time;
    node (int x,int y,int time)
    {
        this->x=x;
        this->y=y;
        this->time=time;
    }
};
int map[maxint][maxint];
int backup[maxint][maxint];
int path[maxint][maxint];
int dir[4][2]={-1,0,1,0,0,-1,0,1};
struct nodecmp
{
    bool operator() (const node &a,const node &b)
    {
        return a.time>b.time;
    }
};
void rprint(int px,int py)
{
    if(px==0&&py==0) return;
    int a=px-dir[path[px][py]][0];
    int b=py-dir[path[px][py]][1];
    rprint(a,b);
    printf("%ds:(%d,%d)->(%d,%d)\n", ++pt, a, b, px, py);
    while(backup[px][py]--)
    {
        printf("%ds:FIGHT AT (%d,%d)\n", ++pt, px, py);
    }
}
int bfs(int n,int m)
{
    priority_queue<node,vector<node>,nodecmp> pq;
    fil(path,-1);
    pq.push(node(0,0,0));
    map[0][0]=-1;
    while(pq.size())
    {
        node temp=pq.top();
        if(temp.x==n-1&&temp.y==m-1) return temp.time;
        pq.pop();
        rep(i,0,3)
        {
            int px=temp.x+dir[i][0];
            int py=temp.y+dir[i][1];
            if(px>=0&&px<n&&py>=0&&py<m&&map[px][py]!=-1)
            {
                int t=temp.time+1+map[px][py];
                map[px][py]=-1;
                path[px][py]=i;
                pq.push(node(px,py,t));
            }
        }
    }
    return 0;
}
int main()
{
    int n,m;
    char in;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        rep(i,0,n-1)
        {
            rep(j,0,m-1)
            {
                scanf(" %c",&in);
                if(in=='.') map[i][j]=0;
                else if(in=='X') map[i][j]=-1;
                else map[i][j]=in-'0';
                backup[i][j]=map[i][j];
            }
        }
        int ans=bfs(n,m);
        if(ans)
        {
            pt=0;
            printf("It takes %d seconds to reach the target position, let me show you the way.\n",ans);
            rprint(n-1,m-1);
        }
        else printf("God please help our poor hero.\n");
        printf("FINISH\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值