HDU1052 Tian Ji -- The Horse Racing(贪心)

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27442    Accepted Submission(s): 8164


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0
 

Source

2004 Asia Regional Shanghai 

http://acm.split.hdu.edu.cn/showproblem.php?pid=1052

好厉害的贪心题

田忌和齐桓公赛马

有n场比赛,每个人都有n匹马

齐桓公从大到小的顺序出马

田忌怎么出自己的马才能收益最大

赢一场得200,平一场0,输一场-200;

贪心 最好的就是多赢 田忌每匹马都要发挥自己最大作用

对于公的最快的一匹马 田忌最快的马能赢就赢(发挥了最大作用 赢了速度最近自己的)

如果最快的马输 那只有输 那就用自己最慢的马去输

重点 如果两个快马平了 是去平了 还是......

平了不一定最好 如果平了 后面的马赢不了 不如让慢马去输,把这匹快马留在后面赢

这时就看田忌最慢的马了 如果慢马 能赢 公最慢的马就让慢马赢一场

如果慢马赢不了 也就说它没有价值了(反正都是输)不如先让他去 输给公的快马

#include<bits/stdc++.h>
using namespace std;
int cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int a[1005],b[1005];
    int n;
    while(scanf("%d",&n),n)
    {
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<n; i++)
            scanf("%d",&b[i]);
        sort(a,a+n,cmp);
        sort(b,b+n,cmp);
        int TFirst=0,QFirst=0;
        int TEnd=n-1,QEnd=n-1;
        int win=0;
        while(n--)
        {
            if(a[TFirst]>b[QFirst])//田忌最快的马比齐王最快的快
            {
                TFirst++,QFirst++;
                win++;
            }
            else if(a[TEnd]>b[QEnd])//田忌最慢的马比齐王最慢的快
            {
                TEnd--,QEnd--;
                win++;
            }
            else if(a[TEnd]<b[QFirst])//用田忌最慢的马与齐王最快的马比
            {
                win--,TEnd--;
                QFirst++;
            }
        }
        printf("%d\n",win*200);
    }
    return 0;
}

这份代码不知道是哪个大神的 没转载链接了SORRY

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值