HDU5933 (贪心)

ArcSoft's Office Rearrangement

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 226    Accepted Submission(s): 108


Problem Description
ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are N working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into K new blocks by the following two operations:

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the minimum operations to re-arrange current blocks into K block with equal size, please help him.
 

Input
First line contains an integer T , which indicates the number of test cases.

Every test case begins with one line which two integers N and K , which is the number of old blocks and new blocks.

The second line contains N numbers a1 , a2 , , aN , indicating the size of current blocks.

Limits
1T100
1N105
1K105
1ai105
 

Output
For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum operations.

If the CEO can't re-arrange K new blocks with equal size, y equals -1.
 

Sample Input
  
  
3 1 3 14 3 1 2 3 4 3 6 1 2 3
 

Sample Output
  
  
Case #1: -1 Case #2: 2 Case #3: 3
 

Source

2016年中国大学生程序设计竞赛(杭州)  

http://acm.split.hdu.edu.cn/showproblem.php?pid=5933

原来有N堆数 现在要分成M堆都相等的

每次只能相邻的合并,OR一堆分成2堆(和要一样就OK了)

问最少要多少次操作

我的思路是贪心

对每一堆少了就向后面拿多了就给后面的 等于平均的就不动

被64位坑得要死10^5*10^5 100亿了 RE了五次

#include<bits/stdc++.h>
using namespace std;
const int maxx=1e5+10;

__int64 aa[maxx];
__int64 cnt;

int main()
{
   __int64 t,i,h,pp,sum,n,m,k;
    scanf("%I64d",&t);
    for(h=1; h<=t; h++)
    {
        scanf("%I64d%I64d",&n,&m);
        sum=(__int64)0;
        for(i=1; i<=n; i++)
        {
            scanf("%I64d",&aa[i]);
            sum+=aa[i];
        }
        if(sum%m)
        {
            printf("Case #%I64d: -1\n",h);
            continue;
        }
        pp=sum/m;
        cnt=(__int64)0;

        for(i=1; i<=n; i++)
        {
            if(aa[i]==0||aa[i]==pp)
                continue;
            if(aa[i]>pp)
            {
                aa[i]-=pp;
                cnt++;
                i--;
            }
            else
            {
                k=aa[i];
                while(k!=pp)
                {
                    if(aa[i+1]+k<pp)
                    {
                        k+=aa[i+1];
                        i++;
                        cnt++;
                    }
                    else if(aa[i+1]+k>pp)
                    {
                        aa[i+1]=k+aa[i+1]-pp;
                        k=pp;
                        cnt+=2;
                    }
                    else 
                    {
                        k=pp;
                        i++;
                        cnt++;
                    }
                }
            }
        }
        printf("Case #%I64d: %I64d\n",h,cnt);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值