HDU5971 To begin or not to begin

To begin or not to begin

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 246    Accepted Submission(s): 188


Problem Description
A box contains black balls and a single red ball. Alice and Bob draw balls from this box without replacement, alternating after each draws until the red ball is drawn. The game is won by the player who happens to draw the single red ball. Bob is a gentleman and offers Alice the choice of whether she wants to start or not. Alice has a hunch that she might be better off if she starts; after all, she might succeed in the first draw. On the other hand, if her first draw yields a black ball, then Bob’s chances to draw the red ball in his first draw are increased, because then one black ball is already removed from the box. How should Alice decide in order to maximize her probability of winning? Help Alice with decision.
 

Input
Multiple test cases (number of test cases≤50), process till end of input.
For each case, a positive integer k (1≤k≤10^5) is given on a single line.
 

Output
For each case, output:
1, if the player who starts drawing has an advantage
2, if the player who starts drawing has a disadvantage
0, if Alice's and Bob's chances are equal, no matter who starts drawing
on a single line.
 

Sample Input
  
  
1 2
 

Sample Output
  
  
0 1
 

Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)  

http://acm.split.hdu.edu.cn/showproblem.php?pid=5978

给你N个黑球和一个红球 两个人轮流摸一个 摸到红球就赢

如果先手有优势 就输出1 平势就0 劣势就2

一看我知道了 跟抽奖一样 轮流抽一样的票数中奖概率一样  如果总数是奇数先手多拿一个肯定优势大一点

否则就是平的 (题目还 2 还case<=50都是唬人的)


#include<bits/stdc++.h>
using namespace std;
int main()
{   int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n&1)
            printf("0\n");
        else printf("1\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值