hihocoder 1107 Shortest Proper Prefix

1107 : Shortest Proper Prefix

时间限制:10000ms
单点时限:1000ms
内存限制:512MB
描述

Query auto-completion(QAC) is widely used in many search applications. The basic idea is that when you type some string s in the search box several high-frequency queries which have s as a prefix are suggested. We say string s1 has string s2 as a prefix if and only if the first |s2| characters of s1 are the same as s2 where |s2| is the length of s2.

These days Little Hi has been working on a way to improve the QAC performance. He collected N high-frequency queries. We say a string s is a proper prefix if there are no more than 5 collected queries have s as a prefix. A string s is a shortest proper prefix if s is a proper prefix and all the prefixes of s(except for s itself) are not proper prefixes. Little Hi wants to know the number of shortest proper prefixes given N collected queries.

Hint: the 4 shortest proper prefixes for Sample Input are “ab”, “bb”, “bc” and “be”. Empty string “” is not counted as a proper prefix even if N <= 5.

输入
The first line contains N(N <= 10000), the number of collected queries.

The following N lines each contain a query.

Each query contains only lowercase letters ‘a’-‘z’.

The total length of all queries are no more than 2000000.

Input may contain identical queries. Count them separately when you calculate the number of queries that have some string as a prefix.

输出
Output the number of shortest proper prefixes.

样例输入
12
a
ab
abc
abcde
abcde
abcba
bcd
bcde
bcbbd
bcac
bee
bbb
样例输出
4

//trie树

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <map>
#include <vector>

using namespace std;

struct trie{ //建立一颗字典树
    char key;
    int num;
    trie *next[26];
    trie(){
        num = 0;
        for(int i = 0; i < 26; i++) next[i] = NULL;
    }

};

trie root;//创建根节点

void ins(string s) { //插入新单词
    trie *head = &root;

    for(int i = 0; i < s.size(); i++) {
        int k = s[i] - 'a';

        if(head->next[k] == NULL) {
            trie *node = new trie;
            node->key = s[i];
            head->next[k] = node;

        }
        head = head->next[k];
        head->num++;
    }

}

int ans = 0; //题目所述proper prefix的个数
map<trie *,int>k; //建立一个映射,后面会用到

void bia(trie *head) {//遍历字典树

         for(int i = 0; i < 26; i++) {
            int flag = 0;

            if(head->num <= 5 &&head != &root) {//满足条件的节点
                    if(k[head] != 1)//若此节点之前未统计过
                    ans++;
                    flag = 1; //标记,此节点后面的分支都不用再遍历了
                    k[head] = 1;//已统计过的节点,标记一下
            }

            //不是最后一个节点且前面还没遇到满足条件的节点
             if(head->next[i] != NULL && !flag)        
               bia(head->next[i]);//递归

        }

}

int main(){

    string s;
    int n,m;
    cin >> n;
    while(n--) {
        cin >> s;
        ins(s);
    }

    trie *head = &root;

    bia(head);
    cout << ans;
    return 0;
}
k-shortest c是一种图算法,用于寻找图中从一个起点到一个终点的k条最短路径。该算法可以应用于许多实际问题,例如网络路由,行程规划等。 k-shortest c算法的基本原理是在每一次迭代中,从起点到终点寻找一条最短路径,并将其添加到结果集中。然后,根据路径长度对图中的边进行更新,使得之后的迭代可以找到更短的路径。这个过程会重复k次,直到找到k条最短路径为止。 该算法可以通过以下步骤实现: 1. 设置起点和终点,并初始化结果集为空。 2. 在每次迭代中,使用Dijkstra或A*等最短路径算法找到一条最短路径。 3. 将找到的最短路径添加到结果集中。 4. 更新路径中的边的权值,使得之后的迭代可以找到更短的路径。 5. 重复步骤2-4,直到找到k条最短路径为止。 k-shortest c算法的优点是能够在不遍历整个图的情况下找到多条最短路径,从而减少了计算量。它可以提供多个解决方案供选择,使得问题的解决更加灵活。 然而,k-shortest c算法也存在一些问题。首先,随着k值的增加,算法的计算复杂度也会增加,因此在实际应用中需要权衡计算资源和最优解之间的平衡。其次,算法在处理大规模图形时可能会受到内存和计算能力的限制。 在总结中,k-shortest c是一种寻找k条最短路径的图算法,适用于各种实际问题。它通过迭代找到一条条最短路径,并更新路径的边权值,以获得更多的解决方案。尽管算法存在一些限制,但它仍然是解决某些问题的有效工具。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值