UVA 10129 Play on Words

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve
it to open that doors. Because there is no other way to open the doors, the puzzle is very important
for us.
There is a large number of magnetic plates on every door. Every plate has one word written on
it. The plates must be arranged into a sequence in such a way that every word begins with the same
letter as the previous word ends. For example, the word ‘acm’ can be followed by the word ‘motorola’.
Your task is to write a computer program that will read the list of words and determine whether it
is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to
open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file.
Each test case begins with a line containing a single integer number N that indicates the number of
plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word
contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will
appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that
the first letter of each word is equal to the last letter of the previous word. All the plates from the
list must be used, each exactly once. The words mentioned several times must be used that number of
times.
If there exists such an ordering of plates, your program should print the sentence ‘Ordering is
possible.’. Otherwise, output the sentence ‘The door cannot be opened.’
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.

//单词接龙,输入多个单词,判断能否首尾相连成一条链,就是一个欧拉回路的题
//关于欧拉回路:对于无向图,度数为奇数的点为奇点,无向图是连通的且最多有两个奇点则一定存在欧拉回路;对于有向图,最多有两个点的入度不等于出度,且其中一个出度恰好比入度大1(把它作为起点),另一个的入度比 出度大1(把它作为终点),当然忽略方向后,图必须连通

//判断连通可以用dfs也可以用并查集

#include "iostream"
#include "string"
#include "cstdio"
#include "cstring"
#include "cmath"
#include "map"
#include "algorithm"
using namespace std;

int p[26];
int indeg[26],outdeg[26];

//并查集
int Find(int x) {

   if(x != p[x]) {
    p[x] = Find(p[x]);
    return p[x];
   }

   return x;
}

//将两个集合合为一个
int link(int x,int y) {
    x = p[x];
    y = p[y];
    if(x != y) p[x] = y;
}

bool okdeg(){   // 判断出度与入度数量是否符合欧拉回路
    bool flag1 = 0,flag2 = 0;

    for(int i = 0; i < 26; i++) {
      if(indeg[i]!=outdeg[i]) {
        if(indeg[i] == 1 + outdeg[i] && !flag1) flag1 = true;
        else if(indeg[i] + 1 == outdeg[i] && !flag2) flag2 = true;
        else return false;
      }
    }

    return true;

}

int main(){
    ios::sync_with_stdio(false);
    int t,n;
    string s;
    cin >> t;
    while(t--) {
        cin >> n;

        memset(p,0,sizeof(p));
        memset(indeg,0,sizeof(indeg));
        memset(outdeg,0,sizeof(outdeg));

        for(int i = 0; i < 26; i++) p[i] = i;  //初始化并查集

        while(n--) {
            cin >> s;
            int u = s[0] - 'a';
            int v = s[s.size()-1] - 'a';
            indeg[u]++;
            outdeg[v]++;
            link(u,v);
        }

        if(okdeg()) {

             int ok = 0;  //判断连通性,若ok大于1,则有2个及以上个集合,即图不连通
             for(int i = 0; i < 26; i++) {
                if(indeg[i] + outdeg[i]) {
                    if(i == p[i])
                       ok++;
                }
             }

             if(ok > 1 ) cout << "The door cannot be opened." << endl;
             else cout << "Ordering is possible." << endl;
        }
       else cout << "The door cannot be opened." << endl;
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值