HDOJ 1002 A + B Problem II //高精度加法

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110


AC代码:


#include <stdio.h>
#include <math.h>
#include <string.h>
int main()
{
	char str1[1000],str2[1000];
	int str[1001]={0};
	int t,T,i,j,r,len1,len2;
	scanf("%d",&T);
	t=T;
	while (T--){
		memset(str,0,sizeof(str));
		memset(str1,0,sizeof(str1));
		memset(str2,0,sizeof(str2));
		/*一开始三个数组都没初始化,str没初始化直接导致每次得到的结果总是 该组数据和前几组数据结果之和
                这个错误比较容易发现 比较隐蔽的是str1和str2没初始化,在本地编译器得到的结果也是正确的
                而提交之后一直WA 但是检查整个程序在思路上应该是没问题的
                最后只能蛮试一下 就把str1和str2给初始化 结果AC了…ORZ
                因此,在进行多组数据输入的时候 一定要把记录数据的相关变量都初始化一遍*/ 
		scanf("%s",str1);
		scanf("%s",str2);
		len1=strlen(str1);
		len2=strlen(str2);
		r=len1-len2;
		for (i=(r>=0?len1-1:len2-1);i>=fabs(r);i--){//用abs竟然会报CE,想不通,改为fabs就OK了
			str[i+1]+=(r>=0?(str1[i]+str2[i-r]-2*'0'):(str2[i]+str1[i+r]-2*'0'));
			if (str[i+1]>=10){
				str[i]++; //逢十进位
				str[i+1]-=10; //自身则应减十  
			}	
		} 
		for (i=fabs(r)-1;i>=0;i--){
			str[i+1]+=(r>=0?(str1[i]-'0'):(str2[i]-'0'));
		}
		for (i=0;i<(r>=0?len1+1:len2+1);i++){
			if (str[i]!=0){
				j=i;
				break;
			}
		}//不能输出前导0,要先判断从第几个开始非零
		printf("Case %d:\n%s + %s = ",t-T,str1,str2);
		for (i=j;i<(r>=0?len1+1:len2+1);i++)
			printf("%d",str[i]);
		if (T!=0)
			printf("\n\n") ;
		else
			printf("\n");//最后一组数据只能输出一个\n
		}
	return 0;
} 
/*本题是进行大数运算,一般像 __int64(-2^63~2^63-1)或long long都不能存储如此大的数(可达1000位)
因此把数字一个一个分解放到数组里 再单个累加 最后输出即可 */


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值