【HDOJ 1003】 Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 


解题思路:

求最大子串和。状态转移方程为:s[i].sum = (s[i-1].sum < 0) ? num[i] : sum[i-1].sum + num[i]; (s[i].sum为 以第i个位置为结尾的所有子串中最大的和)最后对s[i].sum(i = 1,...,n)排序求最大值就行了。用到结构体,存有sum,start,end等信息。

参考代码:

#include <cstdio> 
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 100010;
struct P{
    int start;
    int end;
    int sum;
}s[maxn];
int num[maxn];
bool cmp(const P& p1,const P& p2){
    return p1.sum > p2.sum;
}
int main()
{
    int T,n,i,k;
    scanf("%d",&T);
    for (k = 1;k <= T;k++){
        memset(s,0,sizeof(s));
        scanf("%d",&n);
        for (i = 1;i <= n;i++)
            scanf("%d",&num[i]);
        s[1].start = s[1].end = 1;
        s[1].sum = num[1];
        for (i = 2;i <= n;i++){
            if(s[i-1].sum < 0){
                s[i].sum = num[i];
                s[i].start = s[i].end = i;
            }else{
                s[i].sum = s[i-1].sum + num[i];
                s[i].start = s[i-1].start;
                s[i].end = i;
            }
        }
        sort(s+1,s+n+1,cmp);
        printf("Case %d:\n%d %d %d\n",k,s[1].sum,s[1].start,s[1].end);
        if (k != T)
            putchar('\n');
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值