【Uva 455】 Periodic Strings

Description

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string “abcabcabcabc” has period 3, since it is formed by 4 repetitions of the string “abc”. It also has periods 6 (two repetitions of “abcabc”) and 12 (one repetition of “abcabcabcabc”).

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2

解题思路

判断一个字符串的最小正周期。
从1枚举到 len,并注意到 能成为周期的数 一定能整除 len,可以减少不必要的循环

参考代码

#include <stdio.h>
#include <string.h>
int main()
{
    int n;
    scanf("%d", &n);
    char s[105];
    while(n--){
        scanf("%s", s);
        int len = strlen(s);
        for(int i = 1; i <= len; i++)//枚举最小正周期1~len
            if(len % i == 0){
                int k;
                for(k = i; k < len; k++)
                    if(s[k] != s[k%i])   break;//判断以当前长度为周期,能不能构成原字符串
                if(k == len){
                    printf("%d\n", i);
                    if(n)   printf("\n");
                    break;
                }//注意输出格式
            }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值