uva 455 Periodic Strings

原题:
A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one
repetition of ”abcabcabcabc”). Write a program to read a character string and determine its smallest period.
Input
The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.
Sample Input
1
HoHoHo

Sample Output
2

中文
给你个字符串,让你找最小的循环周期

#include <bits/stdc++.h>
using namespace std;
const int maxnum=1000000;
int Next[maxnum];
char p[maxnum];
int plen;
void GetNext(char* p,int pLen)
{
    Next[0] = -1;
    int k = -1;
    int j = 0;
    while (j < pLen)
    {
        if (k == -1 || p[j] == p[k])
        {
            ++k;
            ++j;
            Next[j] = k;
        }
        else
        {
            k = Next[k];
        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--)
    {
        cin>>p;
        int ans;
        plen=strlen(p);
        GetNext(p,plen);
        ans=0;
        if(plen%(plen-Next[plen]));
            cout<<plen<<endl;
        else
        {
            ans=(plen-Next[plen]);//plen-Next[plen]就是找一个循环节的长度
            cout<<ans<<endl;
        }
        if(t)
            cout<<endl;
    }
    return 0;
}

思路:
在紫书上面找了个简单字符串练练手,结果发现kmp可以解决~ 利用kmp算法的前缀数组找最小循环节即可
字符串总长度是plen
周期是plen-Next[lpen]
先判断是不是一个周期串plen%(plen-Next[plen]),如果能整除则为周期串,否则就是一个不成周期的字符串,输出原来长度即可

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值