POJ 1094:Sorting It All Out (拓扑排序)

Sorting It All Out

Time limit:1000 ms Memory limit:65768 kB


Problem Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.

Sample Input

4 6
A< B
A< C
B< C
C< D
B< D
A< B
3 2
A< B
B< A
26 1
A< Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.


题意:

一共有n个字母,输入m条大小关系,求每个字母大小次序。一共分三种情况:无法确定严格次序;有环;正常得出结果。对第二种和第三种要求输出是在第几段关系后得到的。

解题思路:

每次输入一条关系,都进行一次拓扑排序,对于三种情况每种返回不同的值,在main函数中处理就好了

Code:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <queue>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;

const int maxn=30;
int mp[maxn][maxn],in[maxn];
vector<int> ans;
int TopSort(int n)
{
    int temp[maxn];
    queue<int> Q;
    for(int i=0;i<n;i++)
        temp[i]=in[i];
    //将所有入度为0的点加入队列
    for(int i=0; i<n; i++)
    {
        if(temp[i]==0)
            Q.push(i);
    }
    ans.clear();
    int flag=0;
    while(!Q.empty())
    {
        if(Q.size()>1)
            flag=1;
        int x=Q.front();
        ans.push_back(x);
        Q.pop();
        for(int i=0; i<n; i++)
        {
            if(mp[x][i])
            {
                temp[i]--;
                if(temp[i]==0)
                    Q.push(i);
            }
        }
    }
    if(ans.size()<n)
        return 0;//有环
    if(flag==1)
        return 1;//无法确定严格次序
    return 2;//正常得出结果
}

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&n!=0&&m!=0)
    {
        mem(mp,0);
        mem(in,0);
        char a,b,c;
        int flag=0;
        for(int i=1; i<=m; i++)
        {
            scanf(" %c%c%c",&a,&b,&c);
            if(flag)
                continue;
            mp[a-'A'][c-'A']=1;
            in[c-'A']++;
            int res=TopSort(n);
            if(res==2)
            {
                printf("Sorted sequence determined after %d relations: ",i);
                for(int i=0;i<n;i++)
                    printf("%c",'A'+ans[i]);
                printf(".\n");
                flag=1;
            }
            else if(res==0)
            {
                printf("Inconsistency found after %d relations.\n",i);
                flag=1;
            }
        }
        if(flag==0)
        {
            printf("Sorted sequence cannot be determined.\n");
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值