This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
甲级第二题的思路很简单,就是将对应项的值加起来并按顺序多项式的指数递减顺序输出即可
#include<iostream>
using namespace std;
int main()
{
int k;
cin>>k;
double a[2000]={0};
for(int i=0;i<k;i++)
{
int x;
double y;
cin>>x>>y;
a[x]+=y;
}
cin>>k;
for(int i=0;i<k;i++)
{
int x;
double y;
cin>>x>>y;
a[x]+=y;
}
int cnt=0;
for(int i=0;i<=1000;i++)
{
if(a[i]!=0) cnt++;
}
cout<<cnt;
for(int i=1000;i>=0;i--)
{
if(a[i]!=0) printf(" %d %.1lf",i,a[i]);
}
return 0;
}
注意要用double型数组,当然vector也可以,我还是习惯数组
甲级的1002还是很简单的