1110 Complete Binary Tree 甲级 xp_xht123

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

解题思路:首先先要理解什么是完全二叉树,完全二叉树就是除了最后一层其他都是满的,最后一层必须保证拥有左孩子,其次该如何判断哪颗是完全二叉树,从根节点开始遍历,如果是完全二叉树,刚好可以填进1 ~ n (根节点位置是1),否则最后一个节点的位置一定大于n,因此使用dfs进行遍历计算,得到树的最终节点编号,注意如果不是完全二叉树,那么输出的是根节点,是的话输出最后一个节点的index编号。

以下是代码:

dfs

void dfs(int u , int k)
{//k表示当前节点u的编号
    if(u == -1) return;
    
    if(k > max_index)
    {
        max_index = k;
        res = u;
    }
    //左儿子2 * x
    dfs(a[u].left , 2 * k);
    //右儿子2 * x + 1
    dfs(a[u].right , 2 * k + 1);
}

完整代码:

#include<iostream>
#include<map>
#include<algorithm>
#include<cstring>

//从根节点开始遍历,如果是完全二叉树,刚好可以填进1 ~ n (根节点位置是1)
//否则最后一个节点的位置一定大于n
using namespace std;

const int N = 30;

struct Node
{
    int left;
    int right;
}a[N];

map<int,int>mp;
int n;
int max_index = 0;
int res = 0;

void dfs(int u , int k)
{//k表示当前节点u的编号
    if(u == -1) return;
    
    if(k > max_index)
    {
        max_index = k;
        res = u;
    }
    //左儿子2 * x
    dfs(a[u].left , 2 * k);
    //右儿子2 * x + 1
    dfs(a[u].right , 2 * k + 1);
}


int main()
{
    memset(a , -1 , sizeof a);
    for(int i = 0;i < n;i ++) mp[i] = 0;
    cin>>n;
    for(int i = 0;i < n;i ++)
    {
        string x,y;
        cin>>x>>y;
        if(x != "-") 
        {
            a[i].left = stoi(x);
            mp[a[i].left] = 1;
        }
        if(y != "-") 
        {
            a[i].right = stoi(y);
            mp[a[i].right] = 1;
        }
    }
    
    int root = -1;
    for(int i = 0;i < n;i ++)
    {
        if(!mp[i]) 
        {
            root = i;
            break;
        }
    }
    
    dfs(root , 1);
    
    if(max_index <= n) cout<<"YES"<<" "<<res<<endl;
    else cout<<"NO"<<" "<<root<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值