数据结构与算法-搜索(三)-深度优先搜索(DFS)

数据结构与算法-搜索(三)-深度优先搜索(DFS)

首先回顾之前已经介绍过的广度优先搜索。在由状态的转移和扩展构成的解答树中,广度优先搜索按照层次遍历所有的状态,直到找到我们需要的状态。

与其相对的,假如我们改变对解答树的遍历方式,改为优先遍历层次更深的状态,直到遇到一个状态结点,其不再有子树,则返回上一层,访问其未被访问过的子树,直至解答树中所有的状态都被遍历完毕。这个过程,类似于树的前序遍历。

注意:

例:Temple of the bone

题目描述:

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower,left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

输入:

The input consists of multiple test cases. The first line of each test case contains three integers N,M,and T(1 < N,M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open,respectively. The next N lines give the maze layout, with each line containing M characters. A characters is one of the following: ‘X’: a block of wall, which the doggie cannot enter; ‘S’: the start point of the doggie; ‘D’: the Door; or

‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

输出:

For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

样例输入:
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
样例输出:
NO
YES

题目大意:有一个N*M的迷宫,包括起点S,终点D,墙X和地面.,0秒时主人公从S出发,每秒能走4个与其相邻的位置中的一个,且每个位置被行走之后都不能再次走入,问是否存在这样一条路径使主人公在T秒时刚好走到D。

在这个问题中,题面不再要求我们求解最优解,而是转而需要我们判定是否存在一条符合条件的路径,所以使用深度优先搜索来达到这个目的。

确定状态三元组(x,y,t),(x,y)为当前点坐标,t为从起点走到该点所需的时间。我们需要的目标状态为(dx,dy,T),其中(dx,dy)为D所在点的坐标,T为所需的时间。初始状态为(sx,sy,0),其中(sx,sy)为S所在点的坐标。

同样,在深度优先搜索中也需要剪枝,我们同样不去理睬被判定不可能存在所需状态的子树,以期能够减少所需遍历的状态个数,避免不必要的超时。

这里我们注意到,主人公没走一步时,其所在位置坐标中,只有一个坐标分量发生增一或者减一的改变,那么两个坐标分量和的奇偶性将发生变化。这样,当主人公走过奇数步时,其所在位置坐标和的奇偶性必与原始位置不同;而走过偶数步时,其坐标和的奇偶性与起点保持不变。若起点的坐标和的奇偶性和终点的坐标和不同,但是需要经过偶数秒使其刚好达到,显然这是不可能的,于是我们直接判定这种情况下,整棵树解答树中都不可能存在我们所需的状态,跳过搜索部分,直接输出NO。

代码如下:
#include <iostream>
#include <cstdio>

char maze[8][8];	// 保存地图信息
int n,m,t;			// 地图大小为n*m,从起点到终点能否恰好t秒
bool success;		// 是否找到所需状态标记
int go[][2] = {
    1,0,
    -1,0,
    0,1,
    0,-1
};

void DFS(int x,int y,int time){	// 递归形式的深度优先搜索
    for(int i = 0 ; i < 4 ; i++){	// 枚举四个相邻的位置
        int nx = x+go[i][0];
        int ny = y+go[i][1];
        if(nx < 1 || nx > n || ny < 1 || ny > m) continue;	// 若坐标在地图外则跳过
        if(maze[nx][ny] == 'X') continue;
        if(maze[nx][ny] == 'D'){
            if(time + 1 == t){
                success = true;
                return;
            }else continue;
        }
        maze[nx][ny] = 'X';	// 该状态扩展而来的后序状态中,该位置都不能被进过,直接修改该位置为墙
        DFS(nx,ny,time+1);	// 递归扩展该状态,所用时间递增
        maze[nx][ny] = '.';	// 若其后续状态全部遍历完毕,则退回上层状态,将因为要搜索其后续状态而改成墙的位置,改回普通位置
        if(success) return;	// 假如已经成功,则直接返回,停止搜索
    }
}

int main(){
    while(scanf("%d%d%d",&n,&m,&t)!=EOF){
        if(n == 0 && m == 0 && t == 0) break;
        for(int i = 1 ; i <= n ; i++){
            scanf("%s",maze[i]+1);
        }
        success = false;	// 初始化成功标记
        int sx,sy;
        for(int i = 1 ; i <= n ; i++){	// 寻找D的位置坐标
            for(int j = 1 ; j <= m ; j++){
                if(maze[i][j] == 'D'){
                    sx = i;
                    sy = j;
                }
            }
        }
        for(int i = 1 ; i <= n ; i++){	// 寻找初始状态
            for(int j = 1 ; j <= m ; j++){
                if(maze[i][j] == 'S' && (i+j)%2 == ((sx+sy)%2+t%2)%2){
                    maze[i][j] = 'X';	// 将起点标记为墙
                    DFS(i,j,0);			// 递归扩展初始状态
                }
            }
        }
        puts(success == true?"YES":"NO");
    }
    return 0;
}
运行结果:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值