The sum problem

Given a sequence 1,2,3,…N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
Sample Input
20 10
50 30
0 0
Sample Output
[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]
代码如下:

#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <math.h>
using namespace std;

int main(){
    int n,m,sum,a,b;
    while(cin>>n>>m){
        if(n==m&&n==0){
            break;
        }
        // for(int i = 1;i <=n ;i++){    暴力法超时了
        //     sum=0;
        //     for(int j=i;j<=n;j++){
        //         sum+=j;
        //         if(sum==m){
        //             cout<<"["<<i<<","<<j<<"]"<<endl;
        //             break;
        //         }else if(sum>m){
        //             break;
        //         }
        //     }
            
        // }

        //高斯公式法
        for(int i = (int)sqrt(2*m);i >0;i--){
            a=m/i-(i-1)/2;
            b=a+i-1;
            if((a+b)*i==2*m){
                cout<<"["<<a<<","<<b<<"]"<<endl;
            }
        }
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值